ebanking.lu - Crash when closing a window

RESOLVED DUPLICATE of bug 108601

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 108601
17 years ago
8 years ago

People

(Reporter: Michel Poleur, Assigned: Joe Chou)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [BANK], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011125
BuildID:    20011125

Mozilla tries to load a page. The load icon is spinning but nothing displays.
Trying to close the window crashes Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.ebanking.lu
2. Click on "Démarrer Web Banking" (bottom left)
3. A new window opens with nothing in it. Close the window. Crash.

Actual Results:  Mozilla crashes.

Expected Results:  The content of the window must be displayed.

When the window opens, Java loads. Probably, a class checks for the installation
of a piece of software and freezes.

Comment 1

17 years ago
Build ID: 2001 11 26 03. Windows 2000.

Confirm crash: TB38557300G (and will not stop ranting about how stupid
the QFA is which doesn't let me copy-paste the incident id!)

Comment 2

17 years ago
crash on 2001112603/WinNT4 - TB38559286E
Key: +crash
Keywords: crash
CC stephen for talkback TB38559286E

Comment 4

17 years ago
0x00000011
jvm.dll + 0x403f8 (0x6d4603f8)
jvm.dll + 0x40295 (0x6d460295)
jvm.dll + 0x22e31 (0x6d442e31)
jvm.dll + 0x22b9d (0x6d442b9d)
jvm.dll + 0x23e02 (0x6d443e02)
jpins32.dll + 0x87b0 (0x6d2e87b0)
jpins32.dll + 0x39f8 (0x6d2e39f8)
nsHTMLExternalObjSH::PostCreate
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 4230]
XPCWrappedNative::GetNewOrUsed
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 403]
XPCConvert::NativeInterface2JSObject
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcconvert.cpp, line 835]
nsXPConnect::WrapNative
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\nsXPConnect.cpp, line 502]
nsDOMClassInfo::WrapNative
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 812]
nsArraySH::GetProperty
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3580]
nsNamedArraySH::GetProperty
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3622]
XPC_WN_Helper_GetProperty
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 785]
js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2390]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2643]
js_Execute [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 1014]
obj_eval [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1033]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2792]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2792]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3407]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 991]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1214]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1889]
GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 636]
DocumentViewerImpl::LoadComplete
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1180]
nsDocShell::EndPageLoad
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3352]
nsWebShell::EndPageLoad
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 918]
nsDocShell::OnStateChange
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3260]
nsDocLoaderImpl::FireOnStateChange
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 1110]
nsDocLoaderImpl::doStopDocumentLoad
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 749]
nsDocLoaderImpl::DocLoaderIsEmpty
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 647]
nsDocLoaderImpl::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 578]
nsLoadGroup::RemoveRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 530]
PresShell::RemoveDummyLayoutRequest
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6408]
PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6185]
ReflowEvent::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5969]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072] 
Assignee: asa → joe.chou
Status: UNCONFIRMED → NEW
Component: Browser-General → OJI
Ever confirmed: true
QA Contact: doronr → pmac
(Reporter)

Updated

17 years ago
Blocks: 124594
Whiteboard: [BANK]
(Reporter)

Updated

17 years ago
Summary: Crash when closing a window → ebanking.lu - Crash when closing a window
(Reporter)

Comment 5

17 years ago
With build 2002022603, Mozilla doesn't crash anymore. However, it becomes
unusable (menus do not pop up, clicking links doesn't do anything,...). As in
previous builds, the Java application doesn't run and the Java console displays
no error message.

Comment 6

17 years ago
Looks like a dup of bug 108601.  Marking it so.

*** This bug has been marked as a duplicate of 108601 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Comment 9

12 years ago
one of the best references/recommendations I've found for encouraging financial institutions to support firefox is located at bankers on-line web site 

http://www.bankersonline.com/security/security_browserthreat070204.html 

It was written in 2004 during the download.ject attack, but much of it still applies today.  This is a good link to send when contacting banks.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.