Closed Bug 1121488 Opened 5 years ago Closed 5 years ago

port changes from bug 1120476 and bug 1121304 to comm-central

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 38.0

People

(Reporter: froydnj, Assigned: jcranmer)

References

Details

Attachments

(1 file)

- PL_DHashTable::data has been removed, so PL_DHashTableInit and PL_NewDHashTable calls need to be updated.
- PLDHashTableOps::finalize has been removed, so lots of definitions need to be updated (probably just sed -e /PL_DHashFinalizeStub,/d would work, if the gecko patch is any indication).
> (probably just sed -e /PL_DHashFinalizeStub,/d would work, if the gecko patch is any indication).

Some of the lines lack the trailing comma. I'd do it manually, myself, just to be safe. It's not hard.
Bug 1121304 is similar -- it removes PLDHashTableOps::{alloc,free}Table. I'll land its patches at the same time as the patches from bug 1120476 to make the comm-central updating simpler.
Depends on: 1121304
Summary: port changes from bug 1120476 to comm-central → port changes from bug 1120476 and bug 1121304 to comm-central
The patches have landed on mozilla-inbound.
Attached patch Port the bugsSplinter Review
Rather simple patch, fortunately
Assignee: nobody → Pidgeot18
Status: NEW → ASSIGNED
Attachment #8549345 - Flags: review?(kent)
Comment on attachment 8549345 [details] [diff] [review]
Port the bugs

Review of attachment 8549345 [details] [diff] [review]:
-----------------------------------------------------------------

I'll give you r+ if you're happy to take it :)
Attachment #8549345 - Flags: review+
Comment on attachment 8549345 [details] [diff] [review]
Port the bugs

Review of attachment 8549345 [details] [diff] [review]:
-----------------------------------------------------------------

Reviewed changes, also confirmed that it compiles with the prereq patches landed in mozilla-central.

Note though that bug 1121304 was backed out, and these patches can't land until those prereq patches land.
Attachment #8549345 - Flags: review?(kent) → review+
https://hg.mozilla.org/comm-central/rev/7ee1e4040d49
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 39.0
I'll reland the changes need for bug 1121304 when that merges to mozilla-central, since it didn't look like that was going to happen tonight.
Target Milestone: Thunderbird 39.0 → Thunderbird 38.0
> Note though that bug 1121304 was backed out, and these patches can't land
> until those prereq patches land.

They just relanded without change on mozilla-inbound. Hopefully they'll stick this time.
What was checked in is not what was reviewed.

From Checkin:


    1.41 @@ -721,17 +721,16 @@ nsresult nsMsgDatabase::GetHdrFromUseCac
    1.42  PLDHashTableOps nsMsgDatabase::gMsgDBHashTableOps =
    1.43  {
    1.44    PL_DHashAllocTable,
    1.45    PL_DHashFreeTable,
    1.46    HashKey,
    1.47    MatchEntry,
    1.48    MoveEntry,
    1.49    ClearEntry,
    1.50 -  PL_DHashFinalizeStub,
    1.51    nullptr
    1.52  };

From reviewed patch:

 PLDHashTableOps nsMsgDatabase::gMsgDBHashTableOps =
 {
-  PL_DHashAllocTable,
-  PL_DHashFreeTable,
   HashKey,
   MatchEntry,
   MoveEntry,
   ClearEntry,
-  PL_DHashFinalizeStub,
   nullptr
 };

and presumably elsewhere.
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.