If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XUL include script not being included

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
blocker
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Ray Engelking, Unassigned)

Tracking

35 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I have an extension that I created that has been working fine up until this latest release 35 of Firefox.  It no longer works now.
There is a toollbar xul page called pin4ever.xul .  This includes two scripts:
	<script type="application/x-javascript" src="chrome://pin4ever/content/pin.js" />
	<script type="application/x-javascript" src="chrome://pin4ever/content/pin4ever.js" />

The pin4ever.js script accesses a var called Pin4EverPin in the pin.js file.  With Firefox 35 it is giving a Pin4EverPin is not defined error.
What should have happened is it should have been able to access the Pin4EverPin variable.
(Reporter)

Comment 1

3 years ago
There is an error before that error that shows where the problem is, it was a TypeError: redeclaration of variable query.  I had two let statements in there, that somehow it was allowing before, so my bad.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.