In the Advanced search the Component picklist becomes empty after I click on a value in the product picklist

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: francky.vandriessche, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

I open the Advanced Search page in IE9.
I can see the values in the Classification, Product and Components picklist
I select a Product value and the Component Picklist shows the components for that Product.
I select another Product value and the Component Picklist becomes empty.
From then, wathever Product I select, the Component picklist stays empty.


Actual results:

The Component picklist becomes empty, after I selected two times a value in the Product picklist


Expected results:

The Component picklist should always show the component values for the selected Product.

Comment 1

4 years ago
I cannot reproduce using IE11. Which version of Bugzilla do you use exactly? You filed "4.4" in the version field, but the latest version is 4.4.6.
(Reporter)

Comment 2

4 years ago
Hi Frédéric,

It runs fine in Firefox and Chrome, but not using IE9 (Standard in our company)

We run Bugzilla 4.4
Indeed it is not the latest version, but in the release notes of the newer versions, I cannot find anything about solved IE9 problems.
(Reporter)

Comment 3

4 years ago
Problem Solved!

The IE9 webbrowser was using the IE7 engine. (Company decision)

The solution is to force IE9 into "edge" mode by changing the HTML Header.

Add in Httpd.conf on the Apache server:

LoadModule headers_module /usr/lib/apache2/mod_headers.so
<IfModule headers_module>
    Header set X-UA-Compatible: IE=edge
</IfModule>

Comment 4

4 years ago
OK, so that's a config issue, not an upstream bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.