key navigation does not work in menus after using mouse

VERIFIED DUPLICATE of bug 73823

Status

()

Core
Event Handling
P2
normal
VERIFIED DUPLICATE of bug 73823
17 years ago
17 years ago

People

(Reporter: mcs, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
On Windows 2000 at least, keyboard navigation within menus stops working once
you use the mouse to navigate.  This happens in "top level" application menus as
well as in web form menus.

Steps to reproduce:

1) Use the mouse or keyboard to open a menu, e.g., the Tasks menu.

2) Use the up or down arrow keys to move through some menu items.  Works fine.

3) Place the mouse cursor on a menu item.  Now you are using the mouse to
navigate and select menu items (which is correct behavior).

4) Press one of the arrow keys.  The selection jumps but then returns to where
the mouse cursor is (like the keyboard and mouse are fighting for control of the
menu).
(Reporter)

Updated

17 years ago
Priority: -- → P2

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 73823 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.