Closed Bug 1121600 Opened 5 years ago Closed 2 years ago

[keon][inari][otoro][build] b2g build fails with toolchain error gcc < 4.6

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2?)

RESOLVED WONTFIX
blocking-b2g 2.2?

People

(Reporter: stoyan, Unassigned)

References

Details

Attachments

(7 files, 2 obsolete files)

Attached file build.log
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127111021

Steps to reproduce:

I ran the build script against v2.2 branch as usally:
./config.sh inari
./build.sh


Actual results:

Prebuild toolchain error occured:

configure: error: Only GCC 4.6 or newer supported


Expected results:

The build process should compile clean.

The platform is Ubuntu 14.04 with properly cofigured host compilers. The device is inari.
Component: Infrastructure → General
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
I have reproduced this bug on Debian 7.8 .
Summary: [inari][build] b2g build fails with toolchain error gcc < 4.6 → [inari][otoro][build] b2g build fails with toolchain error gcc < 4.6
Assignee: nobody → lissyx+mozillians
Attached file Manifest update (obsolete) —
Attachment #8551843 - Flags: review?(mwu)
Attachment #8551843 - Flags: feedback?(poirot.alex)
Attachment #8551843 - Attachment is obsolete: true
Attachment #8551843 - Flags: review?(mwu)
Attachment #8551843 - Flags: feedback?(poirot.alex)
Attached file Manifest update
Attachment #8551844 - Flags: review?(mwu)
Attachment #8551844 - Flags: feedback?(poirot.alex)
Comment on attachment 8551844 [details] [review]
Manifest update

I don't know about otoro (I don't have this device)
But I applied the same modification to unagi.xml and was able to use my phones again!!
Attachment #8551844 - Flags: feedback?(poirot.alex)
Hmm does the b2g_ics_strawberry branch on bionic work? I would prefer that if we can, though this is probably fine too if we can't.
(In reply to Michael Wu [:mwu] from comment #6)
> Hmm does the b2g_ics_strawberry branch on bionic work? I would prefer that
> if we can, though this is probably fine too if we can't.

b2g_ics_strawberry works. I built master against it. Although not flashed the images but the gecko and gaia separately they work.
Comment on attachment 8551844 [details] [review]
Manifest update

r=me with a switch to b2g_ics_strawberry
Attachment #8551844 - Flags: review?(mwu) → review+
(In reply to Alexandre Poirot [:ochameau] from comment #5)
> I don't know about otoro (I don't have this device)
> But I applied the same modification to unagi.xml and was able to use my
> phones again!!

I'm confused - how would I apply this locally? I don't have either otoro.xml or unagi.xml in my B2G tree.
(In reply to Emanuel Hoogeveen [:ehoogeveen] from comment #9)
> I'm confused - how would I apply this locally? I don't have either otoro.xml
> or unagi.xml in my B2G tree.

It's in .repo/manifests
Thanks! I didn't realize searching excludes hidden directories by default. Rookie mistake I guess :)
Is it just me or Gecko and Gaia are building and flashing ok with only Gonk(?) failing? I am talking about branch v2.2.
Alex told me to takeover this bug.
This PR changes bionic to ics_strawberry and downloads the gcc-4.8 toolchain.
Assignee: lissyx+mozillians → atilag
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8557358 - Flags: review?(mwu)
Attachment #8557358 - Flags: review?(mwu) → review+
I still get this error building the v2.2 branch on a freshly cloned tree:

git clone git://github.com/mozilla-b2g/B2G.git
VARIANT=user BRANCH=v2.2 ./config.sh inari
[copy over saved backup-inari folder]
[create .userconfig with |export CC=gcc-4.6| and |export CXX=g++-4.6| in it]
VARIANT=user BRANCH=v2.2 ./build.sh

gives me

[...]
configure:3164: checking for arm-linux-android-otool
configure: error: Only GCC 4.6 or newer supported
Flags: needinfo?(atilag)
This is because the method to detect the toolchain it's only implemented on master branch of platform_build project. There's no support for other branches than master even for other devices (except for b2g-4.2.2_r1).
Don't know if it worths implementing it. Michael, What do you think?
Flags: needinfo?(mwu)
Flags: needinfo?(atilag)
Duplicate of this bug: 1127837
Any update on this? v2.2 still fails to build on inari (and I assume unagi and otoro as well). master compiles just fine, as do v2.1 and v2.1s, although master is giving me a "Too many links" error when I try to flash the system partition. It's really odd that master theoretically works, but v2.2 is broken forever :\
Flags: needinfo?(mwu)
Hi, this error is still present, I tried today compile the 2.2 branch and got this error.
Any solution? v1.4,v2.0 and v2.1 can compile, I will try with master now.
(In reply to Penserbjorne - MexMod from comment #19)
> Hi, this error is still present, I tried today compile the 2.2 branch and
> got this error.
> Any solution? v1.4,v2.0 and v2.1 can compile, I will try with master now.

Don't waste your time. master fails with other errors.
Yes, master can't compile for Inari.
Hamachi is ok in all branches, but Inari isn't in 2.2 and master.
The same error 

(configure: error: Only GCC 4.6 or newer supported)

occurs compiling for Geeksphone peak. After GP finished support for the peak and keon devices, we users must compile the further versions of FFOS.

2.2 seems to be usable, so the possibility to compile it is essential (for us). Is there any way to cheat the toolchain detection?

Thank you

Rick
FYI, same error for Geeksphone Keon.
These devices are "officially" unsupported, but they can be fixed.
I leave the ownership in case someone else wants to fix it, I could once I finish my actual development, but it's going to take me some time...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8630983 [details]
Bug 1121600 - Fixed keon.xml manifest for branch v2.2. r=_AtilA_

>https://github.com/mozilla-b2g/b2g-manifest/pull/355
Bug 1121600 - Fixed keon.xml manifest for branch v2.0. r=_AtilA_
Attachment #8630984 - Flags: review?(atilag)
Comment on attachment 8630983 [details]
Bug 1121600 - Fixed keon.xml manifest for branch v2.2. r=_AtilA_

>https://github.com/mozilla-b2g/b2g-manifest/pull/355_AtilA_
Attachment #8630983 - Attachment description: Bug 1121600 - Fixed manifests for branch v2.2. r=_AtilA_ → Bug 1121600 - Fixed keon.xml manifest for branch v2.2. r=_AtilA_
Comment on attachment 8630983 [details]
Bug 1121600 - Fixed keon.xml manifest for branch v2.2. r=_AtilA_

>https://github.com/mozilla-b2g/b2g-manifest/pull/355
Comment on attachment 8630983 [details]
Bug 1121600 - Fixed keon.xml manifest for branch v2.2. r=_AtilA_

>https://github.com/mozilla-b2g/b2g-manifest/pull/355
Bug 1121600 - Fixed manifests for branch v2.2. r=_AtilA_
Attachment #8630983 - Attachment is obsolete: true
Attachment #8630983 - Flags: review?(atilag)
Attachment #8630987 - Flags: review?(atilag)
Attachment #8630987 - Attachment description: Bug 1121600 - Fixed keon.xml manifest for branch v2.0. r=_AtilA_ → Bug 1121600 - Fixed keon.xml manifest for branch v2.2. r=_AtilA_
Attachment #8630984 - Flags: review?(atilag) → review+
Attachment #8630987 - Flags: review?(atilag) → review+
Summary: [inari][otoro][build] b2g build fails with toolchain error gcc < 4.6 → [keon][inari][otoro][build] b2g build fails with toolchain error gcc < 4.6
Assignee: atilag → nobody
(In reply to Juan Gomez [:_AtilA_] (CEST) from comment #35)
> https://github.com/mozilla-b2g/b2g-manifest/commit/
> acafa4ba5e2ece6638dea8ce48d581b28ada74ca

this commit is in master but the problem still persist in keon builds

./build.sh gecko
...
configure:3163: checking for arm-linux-android-otool
configure: error: Only GCC 4.6 or newer supported
...
blocking-b2g: --- → 2.2?
avrelaun, do you have time to fix that on v2.2 branch?
Just change v2.2 branch on b2g-manifest/keon.xml so that platform_build component points to "3ce5007ab3562021551a35e2c06d323d1e8ee048" (currently master) revision, and make a fresh build to check that all is working fine.
Flags: needinfo?(avrelaun)
(In reply to Juan Gomez [:_AtilA_] (CEST) from comment #37)
> ...
> Just change v2.2 branch on b2g-manifest/keon.xml so that platform_build
> component points to "3ce5007ab3562021551a35e2c06d323d1e8ee048" (currently
> master) revision, and make a fresh build to check that all is working fine.

Trying the fix that point @_AtilA_ and stop the gcc version error, but the commit https://github.com/mozilla-b2g/b2g-manifest/commit/acafa4ba5e2ece6638dea8ce48d581b28ada74ca create a fetch sync error, note this repo poits is also on master, trying now with the olds bionic references from past commits
Can you also do this for Geeksphone peak? Or is a new bug-report required for this?
Daniel, do the old buonic references work?

Matthias, do it here, it would be better to track all those devices, I guess.
@adrian no, I get another bunch of different errors, the problem now is the latest bionic triggering the fetch error, may be a new bug ticket.
Daniel, I was able to compile a build for the 2.5. Would it help as a reference for your branch?
@Adrian ok I will test this night the bot branches again with the Atila's fix if any problem
hi!
Good News: I was able to compile FFOS 2.5 for peak.
Bad News: The phone currently goes black and restarts every minute or when I press the on/off-button.
BUt I think thats a problem with the screensaver. It's only happening on 2.5 and not on central.
Oh, yes, central also works on peak.
I didn't try 2.2 because it will be "outdated" in the near future ;)

For the problem with the screensaver I will open a new bug (or search for an open one) if it is still existing in one week. (Maybe its just an unfinished "feature")
Until then I will stay with 2.1

Thanks everybody and good night.
Hi Matthias,

The master branches never had any issue to compile. About the bug, we are discussing it here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1195029
Hi!

I posted my solution for display off in https://bugzilla.mozilla.org/show_bug.cgi?id=1195029
There are only two tiny little nuisances left, which I can't figure out on my own:
1) Even with using BRANCH=2.5 on ./config.sh the info on the phone says it uses version 2.6.0.0 with gecko 45 instead of 2.5.0.0 and 44. Is the 2.5 branch not completely revised yet or is this part of the solution for the toolchain error in this bug?
2) There is a bugzilla-lite app on the phone and also a little bugzilla symbol in the statusbar. Can I somehow get rid of these or is this part of 2.5? I double-checked that I didn't use any of the DEBUG options for ./build.sh or .userconfig

wkr Matthias
Flags: needinfo?(avrelaun)
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.