Profiler viewer behaves badly when data overflows

RESOLVED DUPLICATE of bug 1145187

Status

RESOLVED DUPLICATE of bug 1145187
4 years ago
6 months ago

People

(Reporter: u528881, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8549113 [details] [diff] [review]
Saved profile data from run which overflowed

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127110442

Steps to reproduce:

I was attempting to profile my port of DOXBox from https://github.com/dreamlayers/em-dosbox/tree/em-dosbox-svn-sdl2 . It was compiled with Emscripten 1.29.0 and running Windows 3.11 inside the emulator. I was searching for the origin of periodic pausing as described at https://github.com/kripken/emscripten/issues/2404#issuecomment-69857521 Each x86 instruction execution corresponds to a function call, and many instructions are being executed, so there are very many function calls.


Actual results:

After profiling for around 20 seconds, data was only shown for the last few seconds. Attempts to zoom into a specific section of time by selecting it and pressing the + button instead zoomed into a different section. If I merely selected a section of time, it seemed functions listed below didn't accurately show what was happening during that time. They were probably from a different time period. The coloured bars also did not seem to correspond to the FPS graph.

When profiling for 2 or 3 seconds with no overflow, everything worked as expected.


Expected results:

There should be some notification that the profiler overflowed. It would be nice to display the data that exists, and not a whole lot of nothing followed by a bit of data. Most importantly of all, selecting and zooming should properly select the range I want and not a different range.

It would be nice to be able to increase the amount of data that can be saved. However, the main thing I'm asking for is to not get confusing inaccurate data which wastes my time.

Updated

4 years ago
Component: Untriaged → Developer Tools: Profiler
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145187

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.