FF crashes on XP when playing with the file list (open, rename on an image file) on a web image "right-click|save image as"

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: iBenny, Unassigned)

Tracking

({crash})

34 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Right-click on a web image and select "Save image as";
A window opens to chose the destination folder;
Chose one image file in the open window file list and try to :
1- open it
2- rename it


Actual results:

FF crashes


Expected results:

1- image openned
2- image renamed
Can you go to about:crashes and copy/paste the crash IDs that you've reported for this crash? Thanks!
Severity: normal → critical
Flags: needinfo?(stargate)
Keywords: crash
(fwiw, I can't reproduce this on my Windows XP vm, unfortunately)
(Reporter)

Comment 3

3 years ago
bp-db90a82c-3537-4b5f-8e29-e93e72150115	14-01-2015	21:47
bp-719afded-43d9-4553-8523-c7fa92150115	14-01-2015	21:29
bp-781a156d-4904-4cae-8d12-62d272150114	14-01-2015	15:52
bp-9bff1aae-35c3-4b08-9859-ad36b2150114	14-01-2015	15:51
bp-9c104286-e20c-47ed-96cc-140352150101	01-01-2015	16:00
bp-73e868be-058b-4733-a647-82fe22141227	27-12-2014	12:34
bp-20df6b4c-2f36-42df-a1bf-9a84e2141208	08-12-2014	14:47
bp-0468f172-e42a-49fc-b2f7-f35c82141208	08-12-2014	14:29
Flags: needinfo?(stargate)
(Reporter)

Comment 4

3 years ago
The two last crashes happened only by clicking on an image file name in the list ! had no time to right-click on it !!!
Those are a lot of different-looking crashes... all but https://crash-stats.mozilla.com/report/index/73e868be-058b-4733-a647-82fe22141227 involve the JS engine, so tentatively moving this there.

What web page does this happen on?
Flags: needinfo?(stargate)
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
(Reporter)

Comment 6

3 years ago
ALL pages ! I did it again :

I chose an image at random on a google search in the "Image" tab and did a right-click on it,

the context menu (CM) comes but NO menu item can be chosen from it ! The CM is frozen ! 

I had to chose another opened Firefox window and go back to make the CM disapear but then... FF crashes !!!

bp-a7c8643d-ac3e-459e-905a-b54c22150115	15-01-2015	14:55
Flags: needinfo?(stargate)
(Reporter)

Comment 7

3 years ago
Precision:

When I right-click (RC) on the image and select "save image as"; the "save as" window opens. I then select a jpg file in the file list and then, the CM froze...
(Reporter)

Comment 8

3 years ago
Re precision :

...I then select a jpg file in the file list and RC on it. Then, the CM froze...

Ps: you should add a "edit/modify" option on the posts so we don't have to add new one each time...
Sorry for the late response: this got triaged to our team, but still fell through the cracks somehow.

In my experience, this many diverse stacks on a single machine points more towards flakey hardware than a software fault. Most of these crashes are in the middle of a heap or stack traversal of some sort. A number of people with similarly diverse stacks have found memory errors by running memtest86 [1] for a few hours.

Is this still reproducing? If so, could you try running memtest86 on the machine?

1- http://www.memtest86.com/download.htm
Flags: needinfo?(stargate)
(Reporter)

Comment 10

2 years ago
Hi Terrence,

No ! The issue is gone since ?... long ago !

Many thanks and Happy New Year !

Bnoit
Flags: needinfo?(stargate)
Resolving per comment #10.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.