Mozilla freeze when trying to print a page with an <iframe>

VERIFIED DUPLICATE of bug 124041

Status

()

Core
Printing: Output
P3
critical
VERIFIED DUPLICATE of bug 124041
16 years ago
16 years ago

People

(Reporter: Emmanuel Fleury, Assigned: karnaze (gone))

Tracking

({hang})

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

16 years ago
Hi,

I know it sound strange but I try several times and each time I got Mozilla
freezing.

Here is the recipee:

Go to: http://www.geocrawler.com/lists/3/SourceForge/12349/50/7148450/

Then try to print the page to a file (I don't have a printer so I don't know if
it would be the same).

As I am not root (I don't have the right to write in the default directory of
Mozilla). I set the name of the file to something (any name give the same
result, I tried).

Then, I push "Print...". And... freezed ! :-)

Comment 1

16 years ago
Created attachment 59334 [details]
Stack trace

Seems like it is caught in an infinite loop. It takes a while, but it finally
gets to this place and everytime I stop it in the debugger it is basically
sitting with this stack trace.

Comment 2

16 years ago
This seems to be a table or block reflow issue.
Assignee: rods → attinasi
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Created attachment 59345 [details]
somewhat reduced testcase

I will attach the image file that is needed for this example. So, this file
plus the image file will hang. If you remove the img tag from the example it
prints fine. I think the problem is that the image is being pushed to the
second page and badness happens.

Comment 4

16 years ago
Created attachment 59346 [details]
clear.gif

Save this and the previous attachment in a dir

Updated

16 years ago
Keywords: hang

Comment 5

16 years ago
reassigning this to tech evang, the site is using document.layer and ilayer
Assignee: attinasi → bclary
Component: Printing → English: US
Product: Browser → Tech Evangelism
QA Contact: sujay → zach
Version: other → unspecified

Updated

16 years ago
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Summary: Mozilla freeze when I try to print to a file on the given URL. → geocrawler.com - Mozilla freeze when I try to print to a file on the given URL.
Whiteboard: [PROPRIETARY-DOM]

Comment 6

16 years ago
Created attachment 63059 [details]
testcase (online)

Comment 7

16 years ago
Created attachment 63060 [details]
simplified testcase

this testcase shows the real problem. There are no ilayers or document.layer in
it.
Attachment #59345 - Attachment is obsolete: true
Attachment #59346 - Attachment is obsolete: true
Attachment #63059 - Attachment is obsolete: true

Comment 8

16 years ago
sending to Browser -> Printing
Assignee: bclary → rods
Component: US General → Printing
Product: Tech Evangelism → Browser
QA Contact: zach → sujay
Whiteboard: [PROPRIETARY-DOM]
Version: unspecified → other

Updated

16 years ago
Summary: geocrawler.com - Mozilla freeze when I try to print to a file on the given URL. → Mozilla freeze when trying to print a page with an <iframe>

Comment 9

16 years ago
This asserts all over place just trying load the url, so until it loads
correctly I am not going to check out why it doesn't print.
Over to core layout to see why it doesn't load correctly.
Assignee: rods → attinasi

Comment 10

16 years ago
setting milestone to 0.9.8 so it gets looked at 
Target Milestone: --- → mozilla0.9.8

Comment 11

16 years ago
I get these asserts when I tried to print:

###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! ASSERTION: removing frame not in list: 'prevSibling', file
s:\mozilla\layout\base\src\nsFrameList.cpp, line 189
###!!! Break: at file s:\mozilla\layout\base\src\nsFrameList.cpp, line 189

Then we seem to spin forever trying to create continuation frames for an image.

Anyway, downgrading from BLOCKER to NORMAL.
Severity: blocker → normal

Comment 12

16 years ago
Bulk push to next milestone
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Marking nsbeta1+
Keywords: nsbeta1+
hangs when going into print-preview using 2002020512 build on WINXP

Updated

16 years ago
Severity: normal → critical

Comment 15

16 years ago
Trying to print (or preview) the page at the URL
(http://www.geocrawler.com/lists/3/SourceForge/12349/50/7148450/) causes an
assertion:

      NS_ASSERTION(prevSibling, "removing frame not in list");

The frame in questions is a TableRowGroupFrame, and it has a continuation frame
that is getting removed, but cannot be found in the frame list.

I'm not really sure what is happening with a RowGroupFrame getting a
continuation, so I'm sending this to karnaze to look into.
Assignee: attinasi → karnaze
Target Milestone: mozilla0.9.9 → mozilla1.0
(Assignee)

Comment 16

16 years ago

*** This bug has been marked as a duplicate of 124041 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 17

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.