-jsconsole flag should open new Browser Console

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: nick, Unassigned)

Tracking

31 Branch
x86
Mac OS X

Details

OSX 10.8.5.  After building (mach build) with a modified webapprt/content/webapp.js and webapprt/content/webapp.xul, then installing a packaged app (outlook.com), the changes are reflected in the xul but not the JS file.  I can see my changes to webapp.js in my objdir, but even dump statements or syntax errors don't log anything in the installed application.  I've tried uninstalling and reinstalling the app every time between builds, clobber builds, `rm -rf ~/Library/Caches/outlookcom-95fdd31e7961793317aad4f0ccc43faf`, `rm -rf ~/Library/Application\ Support/outlookcom-95fdd31e7961793317aad4f0ccc43faf`.

Myk has confirmed.
I've also tried uninstalling all of my versions of FF and still saw this.
Also, does not seem to make a difference for freshly installed apps (mykzilla) or hosted (mykzilla).
seems like if you run the app from the command line with `-debug <port number>` then you can connect dev tools from another running process of FF and see console.log and Cu.reportError, but not dump.
This might be related to bug 988062. Have you tried clearing the cache and the profile before reinstalling the app?
I just helped \n troubleshoot, and actually the changes are being reflected, but console.log and Cu.reportError calls aren't being logged to the Error Console (which opens when you pass the -jsconsole flag), nor are dump calls being written to stdout.  So the various logging statements that \n added to webapp.js appeared not to be reflected, although they actually were.

I'm unsure about dump, but some investigation with the -debug flag and remote developer tools reveals that console.log and Cu.reportError are writing to the Browser Console.  And passing -jsconsole to Firefox opens the Browser Console.

So the issue here is probably that the Error Console is broken now that Firefox has made -jsconsole open the Browser Console, and the runtime should open the Browser Console too in that case.

(Unsure about dump, that may be a different issue.)
Summary: Changes to webapp.js are not reflected in desktop application → -jsconsole flag should open new Browser Console
Priority: -- → P3
Per bug 1238079, we're going to disable the desktop web runtime and remove it from the codebase, so we won't fix these bugs in it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.