Closed Bug 1121789 Opened 10 years ago Closed 10 years ago

[Privacy Panel][Location Accuracy] Custom Location is not working

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1118155
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

()

Details

(Keywords: privacy)

Attachments

(1 file)

Description: 
After the user set custom location, the websites do not locate the set location correctly.

Repro Steps:
1) Update a Flame device to BuildID: 20150114010205.
2) Navigate to Settings > Privacy Panel.
3) After going through the tutorial pages, select "Location Accuracy".
4) Enable Use geolocation and Use location adjustment.
5) Select "Custom location" on the dropdown menu.
6) On Define custom location screen, choose region/city or enter GPS coordinates.
7) Navigate to Google Maps on Browser.
8) Select the locate button.
9) Select Share on Website Permission dialog.
10) Observe the map.
  
Actual:
The map shows a blank blue area.
  
Expected: 
The map shows the correct location set under Custom Setting.

Note:
- This issue occurs regardless the Region/City or GPS Coordinates.
- Sometimes the devices crashes at step 9, which is filed in bug 1114667.
  
Environmental Variables:
Device: Flame 3.0 Master (319mb, Full Flash)
BuildID: 20150114010205
Gaia: e2a0f7c311119d4a8e160bdfb9e28a0e61a180fc
Gecko: 63006936ab99
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
    
Repro frequency: 10/10
See attached:  video clip, logcat
http://youtu.be/F3DyfIg8W7Y
========================

This issue also reproduces on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 (319mb, Full Flash)
Build ID: 20150114002502
Gaia: 7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko: 748b20315f75
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
This issue does NOT occur on Flame 2.1
Privacy Panel was not implemented on this branch.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150112001215
Gaia: 1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko: 0863fe4b75c3
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware: V18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Status: NEW → RESOLVED
Closed: 10 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: