"Invalid Account" since Earlybird 36 caused by enigmail

RESOLVED INVALID

Status

Thunderbird
Account Manager
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: Thomas Faßnacht, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:Enigmail])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8549321 [details]
Unbenannt.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I updated to Earlybird 36 (bug is still in Earlybird 37) 


Actual results:

I wanted to change my Account Configuration. When i clicked on "Account Settings" all my accounts are listed as "Invalid account ..." (... is the name of the account) - only the Outgoing Server is listed correctly. If I click on one of the invalid accounts nothing shows on the right side of the window, only if I click on the Outgoing Server the usual options show to configure the SMTP.

Going back to Thunderbird 34 shows that setting up the accounts still works and the data is not corrupted or invalid.

Getting my E-Mails with Earlybird 36/37 is still working too.


Expected results:

Setting up and changing accounts is still working

Comment 1

4 years ago
The check displaying the "Invalid account" was introduced long ago. I do not see why it would suddenly trigger now in TB 36/37. Maybe some other module than account manager broke something. After you see this broken account manager, please open Tools->Error console and see if there are any errors reported.
(Reporter)

Comment 2

4 years ago
(In reply to :aceman from comment #1)
> The check displaying the "Invalid account" was introduced long ago. I do not
> see why it would suddenly trigger now in TB 36/37. Maybe some other module
> than account manager broke something. After you see this broken account
> manager, please open Tools->Error console and see if there are any errors
> reported.

The Error console shows:

Zeitstempel: 15.01.2015 21:08:38
Fehler: Error accessing account Axxx@t-online.de: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://messenger/content/AccountManager.js :: at_build :: line 1551"  data: no]
Quelldatei: chrome://messenger/content/AccountManager.js
Zeile: 1566

for each of my accounts.

Comment 3

3 years ago
A third party extension may cause this, see eg. http://sourceforge.net/p/enigmail/bugs/372/ (as was in my case). Personally I didn't even think it was possible for a mere extension to mess up something like this so badly, so let this serve as a note for any related problems that might arise in the future.
(Reporter)

Comment 4

3 years ago
YOu´re right, it was Enigmail.(In reply to pexu+moz-bugzilla from comment #3)

> A third party extension may cause this, see eg.
> http://sourceforge.net/p/enigmail/bugs/372/ (as was in my case). Personally
> I didn't even think it was possible for a mere extension to mess up
> something like this so badly, so let this serve as a note for any related
> problems that might arise in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Updated

3 years ago
Summary: "Invalid Account" since Earlybird 36 → "Invalid Account" since Earlybird 36 caused by enigmail
Whiteboard: [addon:Enigmail]
Duplicate of this bug: 1142283

Comment 6

3 years ago
So what is the current solution to this? Is it possible to update to a compatible Enigmail version (like 1.8)? Or do the users need to temporarily disable Enigmail?
I installed the latest Enigmail nightly, and that fixed it. (The latest release doesn't work on my Thunderbird beta version.)

Gerv

Updated

3 years ago
Duplicate of this bug: 1143390
You need to log in before you can comment on or make changes to this bug.