Closed Bug 1121840 Opened 7 years ago Closed 7 years ago

Use Cu.cloneInto for the result of NFCTag.transceive

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S4 (23jan)
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: allstars.chh, Assigned: allstars.chh)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

Just like Bug 1120862, transceive also has the same problem

isoDep.transceive().then(result => {..})

Error : permission defined to access property 'then'.

So we should use Cu.cloneInto to converting the Uint8Array.
Attached patch Patch.Splinter Review
Attachment #8549410 - Flags: review?(dlee)
Attachment #8549410 - Flags: review?(dlee) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/47e905a0b0f5
Whiteboard: [p=1]
Target Milestone: --- → 2.2 S4 (23jan)
Comment on attachment 8549410 [details] [diff] [review]
Patch.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1109456

User impact if declined: 
Calling MozNFCTag.transceive could trigger Error.

Testing completed: 
Manually.

Risk to taking this patch (and alternatives if risky): 
No.

String or UUID changes made by this patch:
No.
Attachment #8549410 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/47e905a0b0f5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #8549410 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.