When a desktop logged-in user connects to a room, the list of participants shows him as accountless

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: oteo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
See bug 1121416 comment 1. For the desktop user (the first one below) the server is not sending the “account” parameter and the “displayName” is “Guest”:

[{"roomConnectionId":"db4405d2-75fa-45f6-80fb-f8c75e9831e0","displayName":"Guest","owner":false},

{"roomConnectionId":"c87604d8-1aa1-438c-8adf-5ae142210772","displayName":"crdlc39@gmail.com","account":"crdlc39@gmail.com","owner":true}]
(Reporter)

Updated

4 years ago
Blocks: 1121416
I don't think this is an issue - I think it is working as intended. According to the STR from bug 1121416 comment 0:

1. User A creates and shared a room with User B
2. Both user joins the room
3. When the communication finishes, User A taps on room name to open Room details
4. Then taps on History
5. Check the History details

Presumably, there's a 1b step which is where User A shared the room with User B. If so, then User B is using the standalone UI. The link could have been shared with anyone, or multiple people - not necessarily using Firefox, nor are they necessarily signed in.

Even if the standalone UI was incorporated into Firefox desktop for those using desktop (bug 1066019), I would not want to expose their account/name without explicit UI - for instance, if the link had been shared via twitter, or irc, or something, sending the account data would expose the FxA address (or phone number), which the user might not want to do.

I think this is part of the reason we have names for rooms - so that the user can tag them, and then we can say "you had a conversation in '<room title>'".
(Reporter)

Comment 2

4 years ago
OK, thanks for the explanation. I think it makes sense so close it if you want. In any case, for the sake of clarity:

 - If a Room URL is open in a Firefox tab, guest is always used (even if the user is logged in Firefox Browser Hello App).
 - If a Room URL is open via Firefox Browser Hello app the identity used for login in will be used (or guest if user has not logged in)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.