Closed Bug 1122012 Opened 7 years ago Closed 7 years ago

4% android rck2 regression on fx-team (v.37) Jan 12 from push dd9ba31c3cfc

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

I did some retriggers on treeherder:
https://treeherder.mozilla.org/#/jobs?repo=fx-team&filter-searchStr=Android%204.0%20armv7%20API%2010%2B%20fx-team%20talos%20remote-trobocheck2&fromchange=76ca1c8d8baf&tochange=3c53c0e79901

you can see that we go from ~18.40 -> ~19.20 here:
https://hg.mozilla.org/integration/fx-team/rev/dd9ba31c3cfc

we were missing information though for this changeset:
https://hg.mozilla.org/integration/fx-team/rev/7536897c179d, it doesn't seem mobile specific, but I thought I would mention it
:psd, can you look into this and comment if this is what is expected or if there is a way to reduce/remove this regression?
Flags: needinfo?(prabhjyotsingh95)
I think this is expected. Bug 1100315 changes the scrolling speed and so is expected to impact the checkerboarding tests. Depending on the specific characteristics of the test it might increase or decrease checkerboarding and I guess in this case it increased it. However I think we should just accept the new value as a new baseline unless you have arguments against that.
Flags: needinfo?(prabhjyotsingh95)
Also for the record bug 721421 which landed earlier had the potential to significantly increase checkerboarding in any test that exercised it, but none of the tests do exercise that code. That also I would have accepted as a new baseline for checkerboarding because it provides much faster scroll-to-far-away behaviour which users have been wanting for a while.
I am fine accepting this as a new baseline.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.