0.9.5/0.9.6 inconsistency

VERIFIED DUPLICATE of bug 111963

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 111963
17 years ago
17 years ago

People

(Reporter: kitchen_506, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
in a form post of an input type=file element, 0.9.5 would send a blank mime section:

-----------------------------14052820601481053703276429541
Content-Disposition: form-data; name="attachment"; filename=""
Content-Type: application/octet-stream


-----------------------------14052820601481053703276429541

but 0.9.6 does not send even the blank section.

Not sure if it qualifies as a bug, per se, but it's an inconsistency, and made a
private cgi puke on bad input.  I've larted the coder for that, but thought I
would bring it up.

Also propagates through gecko to galeon, at least.

to reproduce:
1) code a file upload form
2) code a cgi that merely lists parameters sent
3) browse + submit under 0.9.5
4) browse + submit under 0.9.6
5) bask in the glory of an inconsistency

I would have used the helper form 'cuz it's cool and all, but the downrevved
version of galeon + gecko 0.9.5 wouldn't let it work right for some reason or
another.
(Assignee)

Comment 1

17 years ago
John, is this related to bug 111963?
Could you take a look please?
Thx!

Comment 2

17 years ago
Yep.

*** This bug has been marked as a duplicate of 111963 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.