Webshots.com - Select buttons hide when you put your mouse over them

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: TucsonTester3, Assigned: doronr)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011126 Netscape6/6.1b1
BuildID:    2001112603

when you are at the photo you want to download and you attempt to click on
download, the bottons dissappear.

Reproducible: Always
Steps to Reproduce:
1.open netscape
2.goto webcrawler.com
3.enter a search word
4.click on  photo
5.click search
6.choose a picture
7.attempt to download

Actual Results:  I found that if you click anyway it does continue to the next page.

Expected Results:  when you move your mouse over the bottons it should have just
high lighted them.

Comment 1

17 years ago
I can't get to the page where the problem is, the URL above shows webshots, yet 
the steps below mentions webcrawler.

Please attach a reduced testcase

Comment 2

17 years ago
Interestingly enough, this bug doesn't happen all the time.  Depending on how
the webpage shows the picture, sometimes the links in question aren't even
there. To see the problem, please follow the steps to reproduce listed below:

1. Launch Netscape
2. Go to www.webcrawler.com
3. Click on Photo to search for photos, and type the word "Photo" in the search box
4. Click on Search
5. Click on the second picture "Rose Petal" to get a larger view of that picture.
6. Hold your mouse over the options on the right hand side (Download Photo into
Webshots, Send as an eCard, Read andPost Comments, etc)
7. Notice that the links disappear when you mouse over them

Screenshot to follow.


Comment 3

17 years ago
Created attachment 59400 [details]
Screenshot of problem

The mouse is actually right over the white box on the right hand side
underneath "Download Photo into Webshots".

Comment 4

17 years ago
Investigated briefly. This seems to be an evangelism issue - they are using
CSS/JS that looks to me (although I admit I'm not totally familiar with the
specs) to be non standard. In IE the background goes black and you can read it fine.

Here are the lines of interest:
<style>
.hnavdef { cursor: default; font-weight: bold; background: 336699; color: 000000; }
.hnavroll { cursor: default; font-weight: bold; background: 000000; color: 000000; }
</style>

and.....

<td onmouseout="this.className='hnavdef'" class="hnavdef"
onmouseover="this.className='hnavroll'" width="100%" align="center"
bgcolor="#336699">

is this.className ok? not sure. Anyway, it's definately not working. And here is
the URL I used to test:

http://webshots.com/g/25/519-sh/10461.html

thanks -mike
(Reporter)

Comment 5

17 years ago
Problem also happens on the Mac OS 8.6, 9.0.4, 9.1, X.
OS: Windows 2000 → All
Hardware: PC → All

Comment 6

17 years ago
Yes, it is bad html on their site
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Select bottons hide when you put your mouse over them → [EVANG]Select bottons hide when you put your mouse over them
Target Milestone: --- → mozilla0.9.9

Comment 7

17 years ago
I was able to test and confirm that the problem does happen windows ME as well.
Using build #2001112603

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1

Comment 8

17 years ago
-->
Assignee: rods → bclary
Status: ASSIGNED → NEW

Comment 9

17 years ago
-> tech evang
Assignee: bclary → doronr
Component: HTML Form Controls → US General
Product: Browser → Tech Evangelism
QA Contact: madhur → zach
Summary: [EVANG]Select bottons hide when you put your mouse over them → Webshots.com - Select bottons hide when you put your mouse over them
Target Milestone: mozilla1.0.1 → ---
Version: other → unspecified

Comment 10

17 years ago
taking
Assignee: doronr → bclary

Updated

17 years ago
Whiteboard: aok

Comment 11

17 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Updated

17 years ago
Keywords: evang500
Summary: Webshots.com - Select bottons hide when you put your mouse over them → Webshots.com - Select buttons hide when you put your mouse over them
Whiteboard: aok
does it now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.