Feature Proposal: Ability to paste numbers into Dialer

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Dialer
--
enhancement
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: Brett Edmond Carlock, Unassigned)

Tracking

({feature, foxfood})

unspecified
ARM
Gonk (Firefox OS)
feature, foxfood

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8549773 [details]
2015-01-15-13-32-39.png

Currently, Gaia's logic to find and make phone numbers clickable leaves much to be desired. I understand the scope of the regex needed to figure out the myriad ways people represent phone numbers is no small task, so I'm understanding of this current behavior.

However, as a means to allow the user some more flexibility/power, I'd like to see the ability for the user to paste into the dialer any number they've copied.

Obviously, there would have to be some input sanitization:
Strip:
( ) . , [ ] - _ ABCDEFGHIJKLMNO QRSTUVWXYZ

Convert:
ext. -> P
ext -> P
x -> P

And possibly others, but that should be a good representation of what needs to be done.

As you can see in the attachment, if the user tap/holds on the dialer, there is a text caret that shows up.
(Reporter)

Comment 1

3 years ago
Created attachment 8549775 [details]
2015-01-15-13-33-00.png

Currently, the user is even able to COPY numbers from the dialer.

This combined with the caret implies the ability to paste into the field, so it is a bit confusing that this is not allowed.

I'd REALLY like to see this feature land. I can't tell you how much easier it would make a lot of my field work.
Do you know what's the cost to implement paste in the dialer, Tamara?
Status: UNCONFIRMED → NEW
Depends on: 1092427
Ever confirmed: true
Flags: needinfo?(thills)
Clearing the NI as we discussed in the sprint planning due to priorities.
Flags: needinfo?(thills)
Duplicate of this bug: 1133280
Duplicate of this bug: 1150455
Duplicate of this bug: 1180454
tracking-b2g: --- → backlog
Flags: needinfo?(ffos-product)
Keywords: feature
Duplicate of this bug: 1184860

Updated

3 years ago
Keywords: foxfood
I'd propose make a smarter copy&paste actions (bug 1199161).

When select a tel number or text starts with tel: and shows dial action in copy & paste float panel. press the action will trigger the dialer.

So we can reuse existing dialer action and not have to implement paste in dialer
Agreed on adding to backlog and foxfooding feature request dashboard.
Flags: needinfo?(ffos-product)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.