If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OTA update fails after uncompression

RESOLVED DUPLICATE of bug 1181372

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1181372
3 years ago
2 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Flame, nightly channel (m-c + gaia master), latest base build, and original build (and updates) from pvt.

Logcat:

I/GeckoUpdater( 2242): Progress [ ================================================== ]
I/GeckoUpdater( 2242): Finished applying update
I/GonkAutoMounter( 2242): Mounted /system partition as read-only
I/Gecko   (  749): *** AUS:SVC readStatusFile - status: failed: 7, path: /data/local/updates/0/update.status
I/GeckoConsole(  749): AUS:SVC readStatusFile - status: failed: 7, path: /data/local/updates/0/update.status
I/Gecko   (  749): UpdatePrompt: Update error, state: failed, errorCode: 7
W/GeckoConsole(  749): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
I/Gecko   (  749): UpdatePrompt: Setting gecko.updateStatus: Install Pending
W/GeckoConsole(  749): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
W/GeckoConsole(  749): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
I/Gecko   (  749): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 7
I/GeckoConsole(  749): AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 7
I/nsVolumeMountLock(  749): nsVolumeMountLock released for 'sdcard'
I/nsVolume(  749): nsVolume: sdcard state Mounted @ '/storage/sdcard' gen 1 locked 0 fake 0 media 1 sharing 0 formatting 0 unmounting 0 removable 0 hotswappable 0
I/AutoMounter(  749): AutoMounter state changed from UMS_CONFIGURED to IDLE
I/AutoMounter(  749): UpdateState: ums:A1C1E0 mtp:A1C0E0 mode:0 usb:1 tryToShare:0 state:IDLE
I/AutoMounter(  749): UpdateState: Volume sdcard is Mounted and inserted @ /storage/sdcard gen 1 locked 0 sharing en-n
I/AutoMounter(  749): UpdateState: Volume sdcard1 is NoMedia and missing

Comment 1

2 years ago
I get different error message using latest m-c PVT build image

Logcat:
I/GeckoUpdater( 1577): Progress [ ================================================== ]
I/GeckoUpdater( 1577): Finished applying update
I/Gecko   (  230): *** AUS:SVC readStatusFile - status: failed: 70, path: /data/local/updates/0/update.status
I/GeckoConsole(  230): AUS:SVC readStatusFile - status: failed: 70, path: /data/local/updates/0/update.status
I/Gecko   (  230): UpdatePrompt: Update error, state: failed, errorCode: 70
E/GeckoConsole(  230): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
I/Gecko   (  230): UpdatePrompt: Setting gecko.updateStatus: Install Pending
E/GeckoConsole(  230): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
E/GeckoConsole(  230): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
I/Gecko   (  230): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 70
I/GeckoConsole(  230): AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 70

STR:
1. Install lastest m-c PVT build image
2. Change OTA URL to https://aus4.mozilla.org/update/3/B2G/40.0a1/20150328160206/flame/en-US/nightly/Boot2Gecko%203.0.0.0-prerelease%20(SDK%2019)/default/default/update.xml
3. Force check update and install update

Environment:
Build ID               20150428160206
Gaia Revision          6e35b0948c42a4398b8a5916015de167121683a1
Gaia Date              2015-04-28 16:06:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.004835
Firmware Date          Wed Apr 29 00:48:47 EDT 2015
Bootloader             L1TC000118D0
Error code 7 is something different.  Once bug 1181372 is fixed, can we have a retest of this bug please?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181372
You need to log in before you can comment on or make changes to this bug.