Low performance when typing in web page address in the Browser

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: mac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [hamachi])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

Type in an address of webpage into address bar of the Browser.


Actual results:

Device is overloaded, after typed in few letters lag happens and some letters are typed multiple times, when correct word order pressed on the keyboard as shown in the sample video:
https://www.youtube.com/watch?v=yVGCiKQBtq8

Pay special attention that usually it ends up with entering double same letter when two different letter were pressed.


Expected results:

Looks like search is too aggressive which kills the performance, maybe there should be delay when search engine starts searching instead of doing it in real time ? Let users type in as many characters as they want firstly. Then when they stop writing after some time, longer than usual time between key pressing, start searching by search engine?
(Reporter)

Comment 1

4 years ago
Found on:

Alcatel One Touch Fire production (got from T-mobile Poland)
B2G version: 3.0.0.0-prerelease master
Platform version: 38.0a1
Build Identifier: 2015015010229
Git commit info: 2015-01-14 16:21:14 bcc76f93
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [hamachi]

Comment 2

4 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.