Unable to add IMAP account. The wizard always says "please enter a valid host name" for IMAP server.

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: toni, Assigned: racham)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm trying to add IMAP account.

On Account Wizard page "Server Information" I selected IMAP as server type and
wrote server name. Whatever I put as server name, wizard _always_ says "Please
enter a valid host name".

This same happens with Netscape 6.2 on this same box. Actually this first
happened with NS6.2, then I installed Mozilla to see if it was bug in Netscape
or something. 

This used to work earlier, but now for some reason it does not work anymore. I
don't remember messing up with anything... ;)


I'm using "default" profile (pressed cancel for profile manager on Netscape6.2
installation, Mozilla did not even ask for profile stuff). 

Here's my profile path:

  C:\WINDOWS\Application Data\Mozilla\Profiles\default\g87pkprt.slt\Mail\Local
Folders


Quite confusing. :)


ps. Mozilla version "Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6)
Gecko/20011120" and Windows is 98, fully updated with Windows Update.
Can you try a new profile ?
run "mozilla -profilemanager"  and create a second test account.

not a blocker..
Severity: blocker → major
(Reporter)

Comment 2

17 years ago
I just created a new profile and I was able to add one account, but second
fails (and second fails on retry also).

My first IMAP server is "localhost", port 10143 (because of SSH-tunnel).
Second is also supposed to be "localhost", but on other port. Even other
host names for IMAP does not work (like mail.example.com -stylish hosts).

ps. Quite major bug, I have to use Outlook for mail now ;)

- Toni
You can't add 2 accounts for the same hostname ->bug 41929.
But other hostnames should work...


(Assignee)

Comment 4

17 years ago
Can you update the the bug with the exact server names you have used while 
creating this accounts..?

thanks.
(Reporter)

Comment 5

17 years ago
Ok, now I found the "bug".

"BUG":

I had set up a profile with name "Toni Willberg" with SMTP server set 
as "localhost:10025", which is legal for "Outgoing Server (SMTP)" -window.

Later I deleted that profile, and accidentally clicked "Don't delete files".

Then I re-created profile with name "Toni Willberg", which obviously causes 
Mozilla to read my old configuration.

At this point I have no IMAP accounts set up. Then I tried to create new IMAP 
account using whatever host as server name, and this _seems_ to give 
error "please enter a valid host name". BUT it should give an error "please 
enter a valid host name for SMTP server" (!).

This is because that "localhost:10025" is valid for "Outgoing Server (SMTP)" -
window, but is not valid for "Server Information" -window where it ask's for 
Incoming Server. It does not ask for Outgoing Server and it 
says "'localhost:10025' is set as your outgoing server..."

SOLUTION:

- change text "please enter a valid host name" to "please enter a valid host 
name for SMTP server" and "please enter a valid host name for IMAP server" 
(depending on which is invalid)

- make sure that <host>:<port> is accepted as valid host, it's very usefull for 
SSH-tunnels

- create a dropdown list for selecting SMTP server on "Server Information" page 
instead of having to change it using "Advanced" -button on "Outgoing Server 
(SMTP)" -page etc.

Comment 6

17 years ago
Toni Willberg, can you reproduce this problem with Mozilla's latest release, 
1.0RC1?
No response from reporter in more than a month -> WFM

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
Verified Worksforme, for awhile now.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.