Slow rendering of many .webm files

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: 328461, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

Opening around 1 to 10 .webm files (2-3 MB each) on a single page works fine, but going up to 20, 30... 100 or so causes firefox to heavily slow down, cpu and ram usage goes up a lot.


Actual results:

Read above.


Expected results:

I noticed the problem just now, but it worked fine few versions ago. I don't remember on which one though. Scrolling page worked smoothly. I'm just guessing that .webm's are needlesly rendered even though they're completly not visible to the user.

Comment 1

4 years ago
Could you give a testcase (html file, URL), please.
Flags: needinfo?(328461)
Keywords: testcase-wanted
(Reporter)

Comment 2

4 years ago
(In reply to Loic from comment #1)
> Could you give a testcase (html file, URL), please.

I noticed this in 4chan thread which already expired, so it might take me a while to find a test case.
Flags: needinfo?(328461)
Component: Untriaged → Video/Audio
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
I'm going to close this because it is probably fixed. Please re-open if this is still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.