Some task manager cards include notifications line at top

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: sfoster, Unassigned, Mentored)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

4 years ago
STR: 
Open several apps and long press home to show task manager. This repro'd for me with Marketplace and the Add to home screen window from browser. 

Some include the blue line that indicates there are unread notifications in the screenshot. 

note the top area of the card is currently implemented as a -moz-element of that app's AppWindow
since it's a screenshot, isn't that expected if you have notifications?
Flags: needinfo?(sfoster)
(Reporter)

Comment 2

3 years ago
Yeah I have come to expect it - though its not strictly tied to the app/window so I could go either way. Francis - is this bug valid or behaviour OK as-is?
Flags: needinfo?(sfoster) → needinfo?(fdjabri)
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 3

3 years ago
The blue line is the notifications indicator, as Naoki mentioned. Leaving Francis flagged on what is expected in Task Manager, specifically.
Flags: needinfo?(firefoxos-ux-bugzilla)
Duplicate of this bug: 1082706
Mentor: etienne
I'd prefer to keep the blue line out of the task manager cards. As you say, Sam, the notifications aren't tied to the app or the window, so they don't help the user to identify the window. Let's pare this down to the essentials.
Flags: needinfo?(fdjabri)
Keywords: polish
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.