Browser ellipsis menu non-responsive from largish pages

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: sfoster, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

4 years ago
I've reproduced about 1/3 times with http://www.w3.org/Style/CSS/Overview.en.html

STR:
Start loading page
Click '...' button to pull up menu

Expected: 
Menu options show up quickly following tap

Actual: 
Menu can be slow to appear - the "..." button appears non-responsive
(Reporter)

Comment 1

4 years ago
I've also had crashes in this state when clicking "show windows". The browser disappears and I get dropped back to homescreen. I didn't see much in the logcat except what looked like low memory condition that dropped it. I couldnt repro that reliably though (one time in maybe 30 attempts?)
Qawanted: please reproduce and see which versions are affected.  I think this affects 2.2 and before as well.
Keywords: qawanted
I couldn't repro the non-responsive ellipsis menu issue. I tried 20 times on 3.0 and all attempts brought up menu instantaneously. I did reproduce the LMK when tapping on Show Windows option and repro rate is about 5/10; it seems to reliably occur when invoking it the 2nd time in the same session.

Device: Flame 3.0 Master (full flash 319MB)
BuildID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

------

Couldn't repro either non-responsive ellipsis menu issue nor LMK issue for Show Window on Flame 2.2. Repro rate: 0/20.

Device: Flame 2.2 (full flash 319MB)
BuildID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Leaving qawanted tag for others to attempt.
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
I was also unable to reproduce the "..." menu issue on Flame 3.0 or Flame 2.2 after 20 attempts each.  Leaving the tag for another to try.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150228032828
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150302074630
Gaia: 181ef7f96c007d2f5378d8a47b31bc48ac7ae185
Gecko: d748d811784f
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
I was able to reproduce this on Flame 3.0 and Flame 2.2.  This is more severe on 2.2 than 3.0 though.

STR:

1. Go to MLB.com
2. While the page is loading keep tap "...". 

Notice there is a long delay before the menu populates the screen. The button will appear unresponsive.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----------------------------------------------------

This issue does not reproduce on Flame 2.1

When the user taps "...", the menu is always shown without a significant delay.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150302001220
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 9bf4c663241f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Let's get a regression window here.
Flags: needinfo?(ktucker)
Keywords: qawanted → regression, regressionwindow-wanted
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
QA Contact: pcheng
QA Contact: pcheng
I apologize but I am mistaken. This does occur on Flame 2.1

We will not be able to get a regression window here. This is a performance issue and there is a slight delay after tapping the ellipses on 2.1 as well.

Environmental Variables:
Device: Flame 2.1 (319mb)(KK)(Full Flash)
BuildID: 20150304002212
Gaia: 7370d456a330882aa6c29cd5a6470b876038a622
Gecko: 81bbb1143b88
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
status-b2g-v2.1: unaffected → affected
Keywords: regressionwindow-wanted
Keywords: regression

Comment 7

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.