[FFOS7715 v2.1][camera]Capture button has no response when attach attachment using front camera.

RESOLVED WONTFIX

Status

P2
critical
RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: jinchao.wang, Assigned: wilsonpage)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [SPRD 394869])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:Capture button is no response when attach attachment using front camera.

Device: SPRD Dophin 7715ea

Steps to Reproduce:
1) open  Messages App
2) attach attachment and select camera
3) when camera is opened, switch camera from back to front

Actual Result:Capture button has no response.All controls button has no response.

Expected Result:function is normal

Repro frequency:4/10,40%

Analysis:I thought it was caused by  my own changes. I removed the sprd_patch, and I can reproduce too. It can reproduce on Flame too. It's a critical problem.
(Reporter)

Comment 1

4 years ago
Hi:
   It's a critical problem on gaia/camera, can you have a look?
Flags: needinfo?(wilsonpage)
Flags: needinfo?(gchen)
Priority: -- → P2
Whiteboard: [SPRD 394869]
(Reporter)

Comment 2

4 years ago
Created attachment 8550174 [details]
record video about Capture button no response
(Assignee)

Comment 3

4 years ago
I flashed 2.1 Gaia + Gecko, but have been unable to reproduce.
Flags: needinfo?(wilsonpage)
(Reporter)

Comment 4

4 years ago
(In reply to Wilson Page [:wilsonpage] from comment #3)
> I flashed 2.1 Gaia + Gecko, but have been unable to reproduce.

Hi Wilson:
  I found a way to reproduce this bug easily: Open camera and switch to front camera as soon as possible.

  when issue reproduced, this log printed:
01-16 21:19:42.186  4271  4271 E GeckoConsole: [JavaScript Error: "TypeError: pictureSize is undefined" {file: "app://camera.gaiamobile.org/js/co      ntrollers/storage.js" line: 187}]
(Reporter)

Comment 5

4 years ago
(In reply to Wilson Page [:wilsonpage] from comment #3)
> I flashed 2.1 Gaia + Gecko, but have been unable to reproduce.

Hi Wilson:
    It's very easy to reproduce. Please note, you should do a cold launch for camera each time, then switch from back to front camera as soon as possible.
Flags: needinfo?(wilsonpage)

Updated

4 years ago
Blocks: 1123554
(Assignee)

Comment 6

4 years ago
Created attachment 8552361 [details] [review]
pull-request (v2.1)
Flags: needinfo?(wilsonpage)
Attachment #8552361 - Flags: review?(jdarcangelo)
(Assignee)

Updated

4 years ago
Assignee: nobody → wilsonpage
(Assignee)

Comment 7

4 years ago
NEW STR (doesn't depend on pick activity):

1. Open Camera app
2. Instantly hammer the 'Toggle Camera' button (top left)

ACTUAL: Camera switches from 'front' to 'back', then controls become disabled/frozen.
EXPECTED: Camera switched from 'front' to 'back' and controls are enabled/usable.
Comment on attachment 8552361 [details] [review]
pull-request (v2.1)

LGTM
Attachment #8552361 - Flags: review?(jdarcangelo) → review+
Flags: needinfo?(gchen)

Comment 9

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.