Closed Bug 1122428 Opened 5 years ago Closed 5 years ago

[Stingray] UI-Transition - Global Activity transition enter / exit

Categories

(Firefox OS Graveyard :: Gaia::TV, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: suchiu, Assigned: suchiu)

References

Details

(Whiteboard: [Stingray-Branch])

Attachments

(2 files)

Animation for enlarging a circle during activity transition
As we discussed offline, please add the same app launch animation to landing app.
Blocks: 1129808
Attached file Pull Request
1. Add circle animation when switching apps
2. Add circle animation on landing app
3. Make circle radius in createCircleAnimation function a fixed number, since we know that our target screen is 1920x1080
4. Change z-index for home closing animation. It is used for opening the background app again on home page.
Attachment #8561145 - Flags: review?(rexboy)
Attachment #8561145 - Flags: review?(im)
Comment on attachment 8561145 [details] [review]
Pull Request

regression found. Please check my comments in PR.
Attachment #8561145 - Flags: review?(im)
Attachment #8561145 - Flags: review?(im)
Comment on attachment 8561145 [details] [review]
Pull Request

Few nits. If possible, please do not use homescreen overlay to hide the wallpaper. I know the origin thought of homescreen overlay is doing the same thing. But we may change it in the future.
Attachment #8561145 - Flags: review?(im) → review+
Comment on attachment 8561145 [details] [review]
Pull Request

For this patch I think John is more appropriate one for reviewing it. So I'll just cancel mine. You can just land it with John's r+.
Attachment #8561145 - Flags: review?(rexboy)
Component: Gaia → Gaia::TV
Whiteboard: [Stingray-Branch]
You need to log in before you can comment on or make changes to this bug.