Keyword Search bookmark URL-encodes search terms inserted after # href fragment

VERIFIED WONTFIX

Status

()

Core
Networking
VERIFIED WONTFIX
3 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

unspecified
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox37 unaffected, firefox38 affected)

Details

(Reporter)

Description

3 years ago
I have a Keyword Search bookmark for Phonebook, Mozilla's employee address book website:

Location: https://phonebook.mozilla.org/tree.php#search/%s
Keyword: phone

After bug 1093611 landed, when I enter Phonebook query like `phone Chris Peterson` into the address bar, Phonebook searches for the URL-encoded string `Chris%20Peterson` (which fails to find my Phonebook entry). The search terms are URL-encoded because they are inserted after the href fragment. Toggling the "dom.url.encode_decode_hash" pref to true fixes the problem.

* Valentin: should this new behavior be considered a Firefox regression or just a website bug for how it uses the # href fragment?
Flags: needinfo?(valentin.gosu)
I see the same issue in Chrome, and IE should be along the same lines.
According to the spec, this is now the expected behaviour, so I guess the bug is in the website.

PS. Even before bug 1093611, url.hash returned 'Chris Peterson', while url.href returned 'http://...tree.php#Chris%20Peterson". Now the hash and href are consistent.
Note: Safari would return encoded spaces in both hash and href. Getting _all_ browsers to be compatible is a bit of a challenge. 

https://url.spec.whatwg.org/#fragment-state
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → WONTFIX
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.