Closed Bug 1122454 Opened 5 years ago Closed 5 years ago

[Flame][Browser]The IME will pops up on Menu page in Browser.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: wangxin, Assigned: evanxd)

Details

(Keywords: regression)

Attachments

(4 files)

[1.Description]:
[Flame][v2.2][Browser] Invoke IME in website, then lock device on Menu page. When you unlock the device, the IME will pops up.
Bug video:"1739.MP4"
Bug log:"logcat_1739.txt"
Found Time:17:39

[2.Testing Steps]: 
1. Launch Browser.
2. Go to "www.baidu.com".
3. Tap the  search box to invoke IME.
4. Tap the "Menu".
5. Tap the Power key to lock device.
6. Unlock the device.

[3.Expected Result]: 
6. The IME shouldn't appear.

[4.Actual Result]: 
6. The IME pops up on "Menu" page.

[5.Reproduction build]: 
Flame 2.2:
Gaia-Rev      7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev   https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ce27f2692382
Build-ID        20150115002505
Version         37.0a2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video Bug video: 1739.mp4
A keyboard regression bug.
Component: Gaia::Browser → Gaia::Keyboard
QA Contact: bzumwalt
Hi William,
We have executed a regressionwindow-wanted. and the repro information is below, please check.

Last Working Environmental Variables:
Device: Flame
Gaia-Rev        068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a074c0112919
Build-ID        20141106040207
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141106.072530
FW-Date         Thu Nov  6 07:25:41 EST 2014
Bootloader      L1TC000118D0

First Broken Environmental Variables:
Device: Flame
Gaia-Rev        1b974ce130eed3988ff5d012c7bd8431c4aba93b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/678dd5860cce
Build-ID        20141106160207
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141106.192853
FW-Date         Thu Nov  6 19:29:04 EST 2014
Bootloader      L1TC000118D0
Flags: needinfo?(whsu)
Hi, SandKing,

Thanks for your help!
Flags: needinfo?(whsu)
Nominate this bug. Bad user experience.
blocking-b2g: --- → 2.2?
Hi William, can you provide which bug causing this issue? Triage: regression, blocking.
blocking-b2g: 2.2? → 2.2+
Component: Gaia::Keyboard → Gaia::System::Window Mgmt
Flags: needinfo?(whsu)
> Last Working Environmental Variables:
> Device: Flame
> Gaia-Rev        068b9711277b06c7d633517f9e1fcb5624bb39b3
> Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a074c0112919
> Build-ID        20141106040207
> Version         36.0a1
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20141106.072530
> FW-Date         Thu Nov  6 07:25:41 EST 2014
> Bootloader      L1TC000118D0
> 
> First Broken Environmental Variables:
> Device: Flame
> Gaia-Rev        1b974ce130eed3988ff5d012c7bd8431c4aba93b
> Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/678dd5860cce
> Build-ID        20141106160207
> Version         36.0a1
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20141106.192853
> FW-Date         Thu Nov  6 19:29:04 EST 2014
> Bootloader      L1TC000118D0

Hi, Howie,

Here is regression window.
Is this the information you need?
Flags: needinfo?(whsu)
:whsu, we are looking for a push log url and a likely pick from QA, like this comment: bug 1124265 comment 3. If you could always provide that as the regression window result that would be great.
Flags: needinfo?(whsu)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #8)
> :whsu, we are looking for a push log url and a likely pick from QA, like
> this comment: bug 1124265 comment 3. If you could always provide that as the
> regression window result that would be great.

Oh! I see.
Thanks Tim! :)

I will share this information to our team members.
Many thanks. Have a nice day!

--- -- - --- -- - --- -- - --- -- - --- -- -

Gecko change causes this bug. Reason as below,

Comparing the two Gaia commits, result shows "There isn't anything to compare.".
Commit - "1b974ce130eed3988ff5d012c7bd8431c4aba93b" is for test purpose.

So, I search the Gecko change, we found it caused by ""

@ Last working Gaia & Gecko =>>> "Issue does NOT repro"
  Gaia-Rev   1b974ce130eed3988ff5d012c7bd8431c4aba93b
  Gecko-Rev  https://hg.mozilla.org/mozilla-central/rev/41adad987d82

@ First Broken Gecko & Last Working Gaia =>>> "Issue DOES repro"
  Gaia-Rev   1b974ce130eed3988ff5d012c7bd8431c4aba93b
  Gecko-Rev  https://hg.mozilla.org/mozilla-central/rev/0c66a9fd9085

@ Gecko push log.
 - https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=0c66a9fd9085

@ Bug ID: NA
Flags: needinfo?(whsu)
William, 0c66a9fd9085 is a merge commit. Would you be able to biset further to find the regressed bug?
Flags: needinfo?(whsu)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #10)
> William, 0c66a9fd9085 is a merge commit. Would you be able to biset further
> to find the regressed bug?

Hi, Tim,

Sorry for the late reply.

We have limited PVT builds to find the regression window even if I did the cross-comparison between in-bound builds and master builds. Squeezing the builds, I found the regression window still locates at builds I listed on comment 9.

Reason as below.
Here are the builds I pulled.
* The PVT "inbound" builds.
  (https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/b2g-inbound-flame-kk-eng/)
  [DIR]	20141106042821/	06-Nov-2014 14:17 (->>> It does NOT reproduce )
        - Gaia:  5b185fb3c26a814787b544cc9ef2770a8b223ec6
        - Gecko: https://hg.mozilla.org/mozilla-central/rev/bc6d28a397c8

  [DIR]	20141106050421/	06-Nov-2014 14:48 (->>> It DOES reproduce )
        - Gaia:  5b185fb3c26a814787b544cc9ef2770a8b223ec6
        - Gecko: https://hg.mozilla.org/mozilla-central/rev/0b4fff979f4d

* The PVT "master" builds.
  ( https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-central-flame-kk-eng/ )
  [DIR]	20141106040623/	06-Nov-2014 13:41  (->>> It does NOT reproduce )
        - Gaia:  068b9711277b06c7d633517f9e1fcb5624bb39b3
        - Gecko: https://hg.mozilla.org/mozilla-central/rev/41adad987d82

  [DIR]	20141106045123/	06-Nov-2014 14:05  (->>> It DOES reproduce )
        - Gaia-Rev   1b974ce130eed3988ff5d012c7bd8431c4aba93b
        - Gecko-Rev  https://hg.mozilla.org/mozilla-central/rev/0c66a9fd9085




Comparing the build name (timestamp), this issue causes by the merge commit ( Gecko: 0c66a9fd9085)
The smallest regression window.

  [DIR]	20141106042821/	06-Nov-2014 14:17  ( It does NOT reproduce )
        - Gaia:  5b185fb3c26a814787b544cc9ef2770a8b223ec6
        - Gecko: https://hg.mozilla.org/mozilla-central/rev/bc6d28a397c8

  [DIR]	20141106045123/	06-Nov-2014 14:05  ( It DOES reproduce )
        - Gaia-Rev   1b974ce130eed3988ff5d012c7bd8431c4aba93b
        - Gecko-Rev  https://hg.mozilla.org/mozilla-central/rev/0c66a9fd9085


Hope these information are helpful.
Otherwise, we need to borrow developer's expertise to narrow down this problem.
Many thanks.
Flags: needinfo?(whsu)
So it might be come from mozilla-inbound instead of b2g-inbound, even fx-team.
Do we build Flame-KK eng on mozilla-inbound tree? Could you locate a regression window there?

If we couldn't find the bug on all these three branches lets send an e-mail to dev-b2g or dev-platform for help.
Flags: needinfo?(whsu)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #12)
> So it might be come from mozilla-inbound instead of b2g-inbound, even
> fx-team.
> Do we build Flame-KK eng on mozilla-inbound tree? Could you locate a
> regression window there?
> 
> If we couldn't find the bug on all these three branches lets send an e-mail
> to dev-b2g or dev-platform for help.

Hi, Tim,

Bug 1124265 comment 3 also found regression window on b2g-inbound.
So far I haven't seen mozilla-inbound build on PVT server.
Different naming?

Perhaps, Kevin knows the answer.

--- -- - --- -- - --- -- - --- -- - --- -- - --- -- -
Hi, Kevin,

May I have your help?
Have you ever seen the mozilla-inbound on PVT server?
All that I saw on PVT server are b2g-inbound builds.
If you know the build location (URL), could you share the information to us?
Many thanks.
Flags: needinfo?(whsu) → needinfo?(ktucker)
Great! :)

WoW. Cool! Build server generated mozilla-inbound build from last November.

But...
The oldest mozilla-inbound build is "20141106150324".
The regression window of this bug is between "20141106042821" and "20141106045123".
So, it is hard to find the precise regression window now.

--- -- - --- -- - --- -- - --- -- - --- -- - --- -- -
Hi, Kevin,

Sorry to disturb you again and again.
I have supported Device QA for a long time.
So, I am unfamiliar with this area.

Do you have better suggestion regarding this case?
If we don't have enough PVT build to find regression window, what can we do to help?
Flags: needinfo?(ktucker)
No worries William. Anything we can do to help. We will take over the regression window from here since we have the builds needed for the window.
Flags: needinfo?(ktucker)
QA Contact: bzumwalt → pcheng
There isn't branch check information so I did one. I won't be able to finish the window today so it'll have to wait til Monday.
(In reply to KTucker [:KTucker] from comment #16)
> No worries William. Anything we can do to help. We will take over the
> regression window from here since we have the builds needed for the window.

Thanks for your help. :)
I will follow your steps to see what I can learn and share with my team member.
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141106050421
Gaia: 5b185fb3c26a814787b544cc9ef2770a8b223ec6
Gecko: 0b4fff979f4d
Version: 36.0a1 (2.2 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141106053322
Gaia: 8ca903fe7b463a6974186e19d5ba667a1d59f02d
Gecko: d6e8daf74fde
Version: 36.0a1 (2.2 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 5b185fb3c26a814787b544cc9ef2770a8b223ec6
Gecko: d6e8daf74fde

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 8ca903fe7b463a6974186e19d5ba667a1d59f02d
Gecko: 0b4fff979f4d

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/5b185fb3c26a814787b544cc9ef2770a8b223ec6...8ca903fe7b463a6974186e19d5ba667a1d59f02d

Caused by Bug 1079748.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Alive, can you take a look at this please? Looks like the work done on bug 1079748 might have caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Sure! Thanks.
Assignee: nobody → alive
Flags: needinfo?(alive)
A simple one - what we need is avoid call browser.focus if there is a browserMenu opened in the appWindow. Please steal from me.
Flags: needinfo?(gduan)
Flags: needinfo?(evanxd)
Sure, thanks. :)
Assignee: alive → evanxd
Flags: needinfo?(evanxd)
Flags: needinfo?(gduan)
The patch already works, but would like to refactor some little things.
(In reply to William Hsu [:whsu] from comment #11)
> ...
> ...
> * The PVT "inbound" builds.
>  
> (https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/b2g-
> inbound-flame-kk-eng/)
>   [DIR]	20141106042821/	06-Nov-2014 14:17 (->>> It does NOT reproduce )
>         - Gaia:  5b185fb3c26a814787b544cc9ef2770a8b223ec6
>         - Gecko: https://hg.mozilla.org/mozilla-central/rev/bc6d28a397c8
> 
>   [DIR]	20141106050421/	06-Nov-2014 14:48 (->>> It DOES reproduce )
>         - Gaia:  5b185fb3c26a814787b544cc9ef2770a8b223ec6
>         - Gecko: https://hg.mozilla.org/mozilla-central/rev/0b4fff979f4d
> 
> * The PVT "master" builds.
>   (
> https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/
> mozilla-central-flame-kk-eng/ )
>   [DIR]	20141106040623/	06-Nov-2014 13:41  (->>> It does NOT reproduce )
>         - Gaia:  068b9711277b06c7d633517f9e1fcb5624bb39b3
>         - Gecko: https://hg.mozilla.org/mozilla-central/rev/41adad987d82
> 
>   [DIR]	20141106045123/	06-Nov-2014 14:05  (->>> It DOES reproduce )
>         - Gaia-Rev   1b974ce130eed3988ff5d012c7bd8431c4aba93b
>         - Gecko-Rev  https://hg.mozilla.org/mozilla-central/rev/0c66a9fd9085
> 
> 
> Comparing the build name (timestamp), this issue causes by the merge commit
> ( Gecko: 0c66a9fd9085)
> The smallest regression window.
> 
>   [DIR]	20141106042821/	06-Nov-2014 14:17  ( It does NOT reproduce )
>         - Gaia:  5b185fb3c26a814787b544cc9ef2770a8b223ec6
>         - Gecko: https://hg.mozilla.org/mozilla-central/rev/bc6d28a397c8
> 
>   [DIR]	20141106045123/	06-Nov-2014 14:05  ( It DOES reproduce )
>         - Gaia-Rev   1b974ce130eed3988ff5d012c7bd8431c4aba93b
>         - Gecko-Rev  https://hg.mozilla.org/mozilla-central/rev/0c66a9fd9085
> 

Comment 11 listed a incorrect regression-window, please skip it.
Please refer to comment 19. It is correct one.
Sorry for any inconvenience!
Comment on attachment 8559059 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27909

Hi Alive,

Could you help to review the patch?

I will add the unit tests once r+.

Thanks.
Attachment #8559059 - Flags: review?(alive)
Comment on attachment 8559059 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27909

See gh and test wanted
Attachment #8559059 - Flags: review?(alive)
Comment on attachment 8559059 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27909

Hi Alvie,

Updated patch for the comments.
Please help to review it again, thanks.
Attachment #8559059 - Flags: review?(alive)
Attachment #8559059 - Flags: review?(alive) → review+
Alive, thanks for the review.
Comment on attachment 8559059 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27909

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1079748
[User impact] if declined: Keyboard will show on the context menu without any user input if users keep the context menu on the screen and close the phone.
[Testing completed]: It works on the local device, and the CI also works well.
[Risk to taking this patch] (and alternatives if risky): Low risk, we just added one new if-condition there.
[String changes made]: None.
Attachment #8559059 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8559059 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Flags: needinfo?(ryanvm)
Hi Ryan,

Would you like to help to land the patch to branch v2.2?
Or you're busy now? I could do this.

Thanks. :)
Your choice. I run the queries multiple times daily.
https://wiki.mozilla.org/Release_Management/B2G_Landing#Automatic_Branch_Uplifts

That said, please resolve the bug when you land on master. Bugs won't show up as needing uplift otherwise.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Sorry, Ryan, got it.
And thanks for the help.
This issue has been verified successfully on Flame2.2&3.0

Flame 2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

Flame 3.0:
Build ID               20150216010344
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.050451
Firmware Date          Mon Feb 16 05:05:02 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.