Investigate making the weak pointer callback act on a zone group

RESOLVED DUPLICATE of bug 1214961

Status

()

Core
JavaScript: GC
RESOLVED DUPLICATE of bug 1214961
3 years ago
a year ago

People

(Reporter: jonco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The weak pointer callback allows the browser to update possibly finalized or moved weak pointers during a GC.  At them moment it must act on all weak pointers in the system, even if the GC only requires it to act on those for a subset of zones.

Although not the main issue, this might help cases like bug 1122196.
(In reply to Jon Coppeard (:jonco) from comment #0)
> The weak pointer callback allows the browser to update possibly finalized or
> moved weak pointers during a GC.  At them moment it must act on all weak
> pointers in the system, even if the GC only requires it to act on those for
> a subset of zones.
> 
> Although not the main issue, this might help cases like bug 1122196.

Is this still a thing?  Because bug 1122196 has since been closed incomplete
Flags: needinfo?(jcoppeard)
(Reporter)

Comment 2

a year ago
This basically happened in bug 1214961.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jcoppeard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1214961
You need to log in before you can comment on or make changes to this bug.