Closed Bug 1122513 Opened 6 years ago Closed 6 years ago

bzpost should be able to use cookie auth

Categories

(Developer Services :: Mercurial: bzpost, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ted, Assigned: ted)

References

Details

Attachments

(2 files, 1 obsolete file)

It sucks that you have to either type your password or have your password in a config file to use bzpost. It should support cookie auth so the "fetch cookies from a Firefox profile" workflow just works like with bzexport. My patch in bug 1120538 makes it so bzpost can get a cookie via mozhg.auth reliably, but bzpost doesn't know how to use it, because Bugsy doesn't support cookie auth currently.
Assignee: nobody → ted
/r/2591 - Update Bugsy to f7271ed194b19d139551b6c942f82cb4dd65ee77
/r/2593 - bug 1122513 - bzpost should be able to use cookie auth

Pull down these commits:

hg pull review -r 2c1ea240755573460943b3e75137e9552d967bd4
Review ping?
Bugsy has already been upgraded since the patches were written.

I wrote a test for this (first patch) and landed your fix patch (with test modifications).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1132111
Thanks for writing the test and landing this!
Attachment #8550347 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.