Closed Bug 1122527 Opened 10 years ago Closed 10 years ago

[e10s] Detached tabs that had videos being played back are displayed with a large throbber after re-attachment

Categories

(Firefox :: Tabbed Browser, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1103177
Tracking Status
e10s ? ---
firefox37 --- affected
firefox38 --- affected

People

(Reporter: avaida, Assigned: handyman)

References

Details

Attachments

(1 file)

Attached image screenshot
Reproducible on:
Nightly 38.0a1 (2015-01-15), only with e10s.

Affected platform(s):
Ubuntu 14.04 LTS 64-bit, Ubuntu 14.04 LTS 32-bit.

Steps to reproduce:
1. Launch Firefox and make sure e10s is enabled from about:preferences → "General" section.
2. Open a new tab and go to http://youtube.com/.
3. Open a random video and let it play.
4. Detach the tab from the window.
5. Attach the tab back to the initial window.

Expected result:
- The tab playing the video can be successfully be detached/re-attached.
- Video & Audio playback is not interrupted by this action.

Actual result:
After being re-attached to the initial window, the tab displays a large throbber and no video, while audio playback is still working.

Additional notes:

- Happens *only with e10s enabled*, using any video format - e.g. ogg, webm, ogv, HTML5, flash.
- Could not determine a regression range. This action is broken since Nightly 35.0a1 (2014-09-21), builds older than that display a different bug/behavior for this scenario.
- I was unable to replicate it on Windows or Mac machines.
Blocks: e10s
tracking-e10s: --- → ?
Assignee: nobody → davidp99
QA Contact: davidp99
Andrei,

How certain are you that mac and Windows don't have this issue?  I'm on an MacBook Pro and I *always* get the spinner after detatching and then reattaching a tab.  This happens regardless of any embedded video.  Like you, I can still hear the movie while the spinner is active.  What's more, if I detatch the tab a second time, the tab contents return.

There is a lot of useful stuff about what's going on in the debug log so this should be doable.  But I want to make sure that we are seeing the same behavior.
Flags: needinfo?(andrei.vaida)
(In reply to David Parks [:handyman] from comment #1)
> How certain are you that mac and Windows don't have this issue?

I was able to reproduce this issue with latest Nightly (Build ID: 20150120030203) *only* with e10s enabled on both Windows and Mac OS X; Encountered 3 intermittent crashes after re-attaching the tab:
- Windows 7 x64: bp-4698ede4-a0d5-4e35-8251-38fc42150121 and bp-0d99ff33-edff-4078-9fda-2efa72150121 (2 out of 7 tries)
- Mac OS X 10.9.5: bp-a3c8cf86-bf86-494d-aa11-c28082150121 -> only the 1st time the tab was re-attached (out of 5 tries)
Flags: needinfo?(andrei.vaida)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: