After enabling an alarm in Clock app, the checkbox briefly flashes back to disabled state.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR:
 1. In the Clock app, add an alarm (if you don't already have one), and go back to the main Clock view.
 2. Tap the alarm checkbox to enable it. (If it's already enabled, disable it, and then re-enable it). Keep a close eye on the checkbox.

ACTUAL RESULTS: The checkbox instantly flashes to a "checked" state, and then briefly flashes back to empty, and then checked again.

EXPECTED RESULTS: No such back-and-forth flashing.


NOTE: This only seems to happen when *enabling* alarms, not when disabling them. It seems to coincide with the appearance of the faded-in message "The alarm is set for N hours from now.", which makes me wonder if it's due to that message.

This might really be a gecko bug, but I'm starting it out as a bug in the Clock app itself.

I'm hitting this on Firefox OS 2.1, on my Flame.  I can't reproduce in the 2.1 & 2.2 simulators on Desktop, so this might only happen on real phone hardware for some reason.
(Reporter)

Updated

4 years ago
Summary: When enabling the bottom-most alarm in Clock, the checkbox briefly flashes to a disabled state → After enabling an alarm in Clock app, the checkbox briefly flashes back to disabled state.

Comment 1

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.