Introduce IGNORE key to DFR

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: mzhilyaev, Assigned: mzhilyaev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: .?)

(Assignee)

Description

4 years ago
DFR should have __IGNORE section that would contain black-listed domains
(Assignee)

Updated

4 years ago
No longer depends on: 1122632
We currently have a filtering function here: https://github.com/mozilla/interest-dashboard/blob/master/lib/Utils.js#L328

It's applied to both classified domains and raw domains (used for topsites).

Ideally we would have DFR handle all blacklisting so we don't need this util function. We can do this if we compute topsites after we've classified a url. However I believe this will require some re-architecture of the current implementation.
Duplicate of this bug: 1116164
(Assignee)

Updated

4 years ago
Assignee: mzhilyaev → nobody

Updated

4 years ago
Iteration: 38.1 - 26 Jan → 38.2 - 9 Feb

Updated

4 years ago
Assignee: nobody → mzhilyaev
(Assignee)

Comment 3

4 years ago
Closing this bug as we are moving towards _SCOPES rules
If we decide to add IGNORE to DFR, we can re-open the bug
Status: NEW → RESOLVED
Iteration: 38.2 - 9 Feb → ---
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.