Breakpoint set on valid lines slides

RESOLVED WORKSFORME

Status

DevTools
Debugger
RESOLVED WORKSFORME
4 years ago
5 days ago

People

(Reporter: Florent Fayolle, Unassigned)

Tracking

(Blocks: 1 bug)

37 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

STR:
1. Open this page: https://www.mozilla.org/en-US/contribute/ (note : must be 
2. Open the Debugger
3. Reload the page (important !)
4. Set a breakpoint at line 218 of tabzilla.js


Actual results:

The breakpoint slides to line 232.


Expected results:

It should remain at line 218
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools: Debugger
(Reporter)

Comment 1

4 years ago
:jimb I cc you (my intuition tells me it is JSD2-related).

Florent
Blocks: 1074182
Confirmed in 38.0a1 (2015-01-19) Win 7
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can no longer repro this bug ( nightly 40 w/e10s ) possibly because tabzilla.js has changed. Can you update with new steps to reproduce the problem?
Flags: needinfo?(fayolle-florent)
Eddy has also landed some improvements with breakpoints so it's possible this was fixed.
(Reporter)

Comment 5

3 years ago
I can't reproduce anymore too.

Florent
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(fayolle-florent)
Resolution: --- → WORKSFORME

Updated

5 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.