Closed Bug 1122746 Opened 5 years ago Closed 5 years ago

Intermittent Windows "pymake\..\..\mozmake.exe: *** [package-tests] Error 1" due to "find: Filesystem loop detected" error

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set

Tracking

(firefox38 wontfix, firefox38.0.5 fixed, firefox39 fixed, firefox40 fixed, firefox-esr31 wontfix, firefox-esr38 fixed, b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
Tracking Status
firefox38 --- wontfix
firefox38.0.5 --- fixed
firefox39 --- fixed
firefox40 --- fixed
firefox-esr31 --- wontfix
firefox-esr38 --- fixed
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.1S --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: jlund, Assigned: mshal)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

this may be the result of some parallel processes being done during the make target:

example: https://tbpl.mozilla.org/php/getParsedLog.php?id=56728846&tree=Mozilla-Inbound

we hit this before when standing up mozharness mach and we tried to run package-tests in a non serial manner: https://bugzilla.mozilla.org/show_bug.cgi?id=1077597


nothing left for buildduty to do. I clobbered the 'bad' slave's build dir and left it in production: b-2008-ix-0114

sheriffs report these instances are becoming less uncommon. keeping bug open to document future instances.
Summary: package-tests step occasionally fails on at least win64 with 'find: Filesystem loop detected' → Intermittent Windows "pymake\..\..\mozmake.exe: *** [package-tests] Error 1" due to "find: Filesystem loop detected" error
It looks like these all fail at the 'find -L dist/test-stage -name '*.pyc' -exec rm {} \;' step. I think that's just used to make sure *.pyc doesn't end up in the tests.zip file. Oddly, we already use the -x option in the zip command to ignore .mkdir.done, so I think we can remove the find and just skip *.pyc during zip as well.

This doesn't fix the underlying problem, but since I can't reproduce it I have no idea what that actually is. I'm hoping by removing the find command we can just work around it.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=02c67f894900
Attachment #8596865 - Flags: review?(ted)
Attachment #8596865 - Flags: review?(ted) → review+
Assignee: nobody → mshal
I should have listened to past me apparently: bug 1126944 comment 3.
Marking leave-open for now, in case this doesn't make the problem go away.
Keywords: leave-open
Well this seems to be gone for inbound/central/fx-team and such. The only recent hits have come from aurora, release, and b2g32. Is this worth uplifting or should we just wait it out?
Yeah, I'll get this on the other branches. Thanks, Mike!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ryanvm)
Keywords: leave-open
Resolution: --- → FIXED
Flags: needinfo?(ryanvm)
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.