SVG <line> and <ellipse> are positioned incorrectly

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Yingjie, Unassigned)

Tracking

35 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.99 Safari/537.36

Steps to reproduce:

I compose HTML script for SVG using JavaScript, like
<svg><ellipse ry="7.5200000000000005%" rx="5%" cy="46.86%" cx="11.41%"/></svg>
then use Angular element.append() command to append this svg element into the DOM.


Actual results:

<line> and <ellipse> are placed at wrong positions. <rect> and <use> are fine. 
If I put markers on <line> using the marker-start or marker-end attribute, the markers appear in the correct place although the line that bears the markers is somewhere else.

This bug is only found on v35. Everything works correctly in v34 and v36(beta). Our site relies heavily on SVG, so I seriously hope a fix can be released sooner than the scheduled release for v36.
(Reporter)

Updated

3 years ago
Severity: normal → blocker
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All

Comment 1

3 years ago
Same bug happens in Windows7 with v35.  It makes using SVG graphics impossible.

Comment 2

3 years ago
Could you attach a minimal test case?
Severity: blocker → normal
Flags: needinfo?(yingjielin.yj)
Priority: P1 → --
(Reporter)

Comment 3

3 years ago
Hi Alice,
I tried to make a simplified test case but I can't reproduce the problem in the test case. I've sent an invite to your email address from the site I build. If you can create a password and login, you will be able to see the problem.
Once logged in, you will see a photo I shared to you. Open the photo, and you will see some markup tools. You can select the 'line' tool or the 'ellipse' tool to make a line or ellipse, and you will see the bug.
Thanks!
Flags: needinfo?(yingjielin.yj)

Comment 4

3 years ago
(In reply to Yingjie from comment #3)

Sorry, I cannot...
(Reporter)

Comment 5

3 years ago
Hi Alice,

What do you mean?
Comment hidden (obsolete)
You said it's fixed in 36. I'm afraid you're going to have to wait till February then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

3 years ago
OK, we'll wait for v36. Thanks.
You need to log in before you can comment on or make changes to this bug.