middlemouse.paste does not replace highlighted text like ctrl+v or context menu pasting does

RESOLVED DUPLICATE of bug 76010

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 76010
3 years ago
3 years ago

People

(Reporter: strider6153, Unassigned)

Tracking

34 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

1. Copy text to the clipboard. 
2. Highlight some text in a textbox or the url bar.
3. Middle click on highlighted text.


Actual results:

When middlemouse.paste is enabled, pasting over highlighted text does not replace the highlighted parts. It only inserts the copied text where the mouse cursor is. This is different to how ctrl+v and context menu pasting works.


Expected results:

It should work exactly like how ctrl+v and context menu pasting does -- whatever is highlighted gets replaced. If it's not highlighted it gets inserted.

Updated

3 years ago
Component: Untriaged → Location Bar

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 76010
(Reporter)

Comment 2

3 years ago
Holy shih tzu this problem has been going on since 2001?! Well the firefox team must be very busy people. I'll check back in 2050.

Comment 3

3 years ago
(In reply to strider6153 from comment #2)
> Holy shih tzu this problem has been going on since 2001?! Well the firefox
> team must be very busy people. I'll check back in 2050.

Hi. Thanks for your feedback. Yes, we are busy.

However, I just had another look, and it looks that this was marked invalid in 2007. See bug 289757 comment 14 for reasoning. (in short: dnd is not the same as pasting)
(Reporter)

Comment 4

3 years ago
If it's not considered pasting why is the name of it middlemouse.paste? Can there be a compromise and you add a option in about:config to let it work like a normal paste? How about you call this feature middlemouse.drop and then add a new option that works like ctrl+v and call that middlemouse.paste?
You need to log in before you can comment on or make changes to this bug.