Enable additional e10s test suites (1/17/15)

RESOLVED DUPLICATE of bug 1215233

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 1215233
3 years ago
2 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1061014 +++

This is the latest push to holly:

https://treeherder.mozilla.org/ui/#/jobs?repo=holly&revision=101b76881ea8

We can enable:

Win7 opt: m1-5, dt, and gl
Win8 opt: m1-5, dt, and gl
Linux opt: gl
Linux64 opt: gl
OS X 10.6 opt: dt
OS X 10.8 opt: dt
(Assignee)

Comment 1

3 years ago
Win7 opt: m1-5, dt, and gl
Win8 opt: m1-5, dt, and gl
Linux opt: gl
Linux64 opt: gl
OS X 10.6 opt: dt, gl
OS X 10.8 opt: dt, gl

added gl to osx.
(Assignee)

Comment 2

3 years ago
sorry, that was supposed to be a plus.
tracking-e10s: m4+ → +
jmaher, armenzg, can you help us out here? These are sets of tests that are now working on holly, with e10s enabled, but aren't running yet on m-c. I would really love to help to get these tests running on m-c, because right now we don't have a lot of test coverage for e10s-enabled Firefox on platforms that aren't Linux-opt. 

I'm looking at this, http://hg.mozilla.org/build/buildbot-configs/file/c4e019fb40c0/mozilla-tests/config.py which is where I think we need to add code to turn on more tests. It is harder to jump into than I thought it would be.  It might be helpful if either you can talk me through starting this, or can take it and then I can work on disabling/skipping and filing bugs on some of the failing tests on holly.
Flags: needinfo?(jmaher)
Flags: needinfo?(armenzg)
Lizzard- this is not my expertise, but that shouldn't stop me from writing patches or helping you write a patch for it.

There is a general test definition for each test type for each platform.  Take a look at linux32 mochitest[plain]-e10s:
http://hg.mozilla.org/build/buildbot-configs/file/c4e019fb40c0/mozilla-tests/config.py#l740

If you scroll down from that point you will see the need to add support for g1.  Also this process can be added for the windows/osx jobs.


When adding support for mochitest-e10s or mochitest-gl-e10s to the specific platforms, there is still a need to define the specific job configuration:
http://hg.mozilla.org/build/buildbot-configs/file/c4e019fb40c0/mozilla-tests/config.py#l432

For the most type, the core job configuration is just adding --e10s to the argument list.


Once that is in place, the magic takes place here:
http://hg.mozilla.org/build/buildbot-configs/file/c4e019fb40c0/mozilla-tests/config.py#l2117

That should give you a pointer.  While doing this, you can feel free to ask me for feedback.  Likewise there is a tool for testing locally:
https://wiki.mozilla.org/ReleaseEngineering:TestingTechniques#List_builders_added.2Fremoved

running this with your patch will print out all the changes to jobs- it can be a lot of output, but understanding what your patch changes is worth the time invested.  

For review on the final patch, do ask :catlee or :coop for review.
Flags: needinfo?(jmaher)
Flags: needinfo?(armenzg)

Comment 5

3 years ago
Let me know if I can assist in any way.
Armen, I never did manage this and I have moved to the release management team. 
Is this something you or maybe releng can take over ?
Flags: needinfo?(armenzg)

Comment 7

3 years ago
Sure.

jimm, what is the most up-to-date list?
Assignee: nobody → armenzg
Flags: needinfo?(armenzg)
(Assignee)

Comment 8

3 years ago
(In reply to Jim Mathies [:jimm] from comment #1)
> Win7 opt: m1-5, dt, and gl
> Win8 opt: m1-5, dt, and gl
> Linux opt: gl
> Linux64 opt: gl
> OS X 10.6 opt: dt, gl
> OS X 10.8 opt: dt, gl
> 
> added gl to osx.

hmm unfortunately we have some new perma failures so this list needed to be slimmed down - 

Win7 opt: m1, m2, m4, m5, dt, gl
Linux opt: dt, gl
Linux64 opt: dt, gl
OS X 10.6 opt: dt, gl
OS X 10.8 opt: dt, gl

If I disable 'test_peerConnection_basicH264Video.html' for e10s on win7 opt I think we can add back m3 to get a full set.
FWIW, OSX 10.8 is being transitioned to OSX 10.10 on trunk. Also, given our extreme lack of rev5 test slaves (which are responsible for both 10.8 and 10.10 testing), I would be strongly opposed to adding even more tests to that pool which is already suffering from chronic backlog.
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #9)
> FWIW, OSX 10.8 is being transitioned to OSX 10.10 on trunk. Also, given our
> extreme lack of rev5 test slaves (which are responsible for both 10.8 and
> 10.10 testing), I would be strongly opposed to adding even more tests to
> that pool which is already suffering from chronic backlog.

I strongly agree with Ryan here.

I'm fine with 10.8 tests being added as non-default on Try, but we simply don't have the 10.8 capacity to enable new tests everywhere right now.
(Assignee)

Comment 11

3 years ago
nixing 10.8 is fine with me.

Armen, let me take this briefly to get those win7/win8 opt mochitests cleaned up, then I'll flip it back to you with a final list of tests.
Assignee: armenzg → jmathies

Comment 12

3 years ago
I will be gone next week.
I can get you the buildbot-configs and you can tweak depending on where we are at the time you're ready?
(Assignee)

Comment 13

3 years ago
(In reply to Armen Zambrano - Automation & Tools Engineer (:armenzg) from comment #12)
> I will be gone next week.
> I can get you the buildbot-configs and you can tweak depending on where we
> are at the time you're ready?

sure, or if you want you can just wait until you're back. I won't get to this bug this week anyway.
(Assignee)

Comment 14

3 years ago
I just merged holly and did some retriggers on 

WinXP opt: m1-5, gl
Win7 opt: m1-5, gl
Win8 opt: m1-5, gl

lets start by getting these going.
(Assignee)

Comment 15

3 years ago
Created attachment 8588591 [details] [diff] [review]
buildbot configs
(Assignee)

Comment 16

3 years ago
Comment on attachment 8588591 [details] [diff] [review]
buildbot configs

Review of attachment 8588591 [details] [diff] [review]:
-----------------------------------------------------------------

This has the main suites we wanted to add. I've also moved the comment headers down to individual lines since this was getting a bit hard to decipher.

added:

m1-5:
winxp opt, win7 opt, win8 opt

gl:
winxp opt, win7 opt, win8 opt
osx 10.10 opt

bc1-bc3:
win7 dbg
osx 10.10 opt
osx 10.10 dbg
Attachment #8588591 - Flags: review?(armenzg)

Comment 17

3 years ago
I will look into detail this afternoon but for now this is what is getting added:

(From the braindump repo)
$ ./list_builder_differences.sh -j ~/moz/patches/e10s.diff -f -p
+ Rev5 MacOSX Yosemite 10.10 ash debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 ash debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 ash debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 cedar debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 cedar debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 cedar debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 cypress debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 cypress debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 cypress debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 fig debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 fig debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 fig debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 fx-team debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 fx-team debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 fx-team debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 gum debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 gum debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 gum debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 jamun debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 jamun debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 jamun debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 maple debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 maple debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 maple debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 mozilla-central debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 mozilla-central debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 mozilla-central debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 oak debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 oak debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 oak debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 try debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 try debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 try debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit ash debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit ash debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit ash debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit ash opt test mochitest-e10s-1
+ Windows 7 32-bit ash opt test mochitest-e10s-2
+ Windows 7 32-bit ash opt test mochitest-e10s-3
+ Windows 7 32-bit ash opt test mochitest-e10s-4
+ Windows 7 32-bit ash opt test mochitest-e10s-5
+ Windows 7 32-bit b2g-inbound debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit b2g-inbound debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit b2g-inbound debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-1
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-2
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-3
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-4
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-5
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-1
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-2
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-3
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-4
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-5
+ Windows 7 32-bit cedar debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit cedar debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit cedar debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit cedar opt test mochitest-e10s-1
+ Windows 7 32-bit cedar opt test mochitest-e10s-2
+ Windows 7 32-bit cedar opt test mochitest-e10s-3
+ Windows 7 32-bit cedar opt test mochitest-e10s-4
+ Windows 7 32-bit cedar opt test mochitest-e10s-5
+ Windows 7 32-bit cypress debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit cypress debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit cypress debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit cypress opt test mochitest-e10s-1
+ Windows 7 32-bit cypress opt test mochitest-e10s-2
+ Windows 7 32-bit cypress opt test mochitest-e10s-3
+ Windows 7 32-bit cypress opt test mochitest-e10s-4
+ Windows 7 32-bit cypress opt test mochitest-e10s-5
+ Windows 7 32-bit fig debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit fig debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit fig debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit fig opt test mochitest-e10s-1
+ Windows 7 32-bit fig opt test mochitest-e10s-2
+ Windows 7 32-bit fig opt test mochitest-e10s-3
+ Windows 7 32-bit fig opt test mochitest-e10s-4
+ Windows 7 32-bit fig opt test mochitest-e10s-5
+ Windows 7 32-bit fx-team debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit fx-team debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit fx-team debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit fx-team opt test mochitest-e10s-1
+ Windows 7 32-bit fx-team opt test mochitest-e10s-2
+ Windows 7 32-bit fx-team opt test mochitest-e10s-3
+ Windows 7 32-bit fx-team opt test mochitest-e10s-4
+ Windows 7 32-bit fx-team opt test mochitest-e10s-5
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-1
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-2
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-3
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-4
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-5
+ Windows 7 32-bit gum debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit gum debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit gum debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit gum opt test mochitest-e10s-1
+ Windows 7 32-bit gum opt test mochitest-e10s-2
+ Windows 7 32-bit gum opt test mochitest-e10s-3
+ Windows 7 32-bit gum opt test mochitest-e10s-4
+ Windows 7 32-bit gum opt test mochitest-e10s-5
+ Windows 7 32-bit gum pgo test mochitest-e10s-1
+ Windows 7 32-bit gum pgo test mochitest-e10s-2
+ Windows 7 32-bit gum pgo test mochitest-e10s-3
+ Windows 7 32-bit gum pgo test mochitest-e10s-4
+ Windows 7 32-bit gum pgo test mochitest-e10s-5
+ Windows 7 32-bit jamun debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit jamun debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit jamun debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit jamun opt test mochitest-e10s-1
+ Windows 7 32-bit jamun opt test mochitest-e10s-2
+ Windows 7 32-bit jamun opt test mochitest-e10s-3
+ Windows 7 32-bit jamun opt test mochitest-e10s-4
+ Windows 7 32-bit jamun opt test mochitest-e10s-5
+ Windows 7 32-bit maple debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit maple debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit maple debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit maple opt test mochitest-e10s-1
+ Windows 7 32-bit maple opt test mochitest-e10s-2
+ Windows 7 32-bit maple opt test mochitest-e10s-3
+ Windows 7 32-bit maple opt test mochitest-e10s-4
+ Windows 7 32-bit maple opt test mochitest-e10s-5
+ Windows 7 32-bit mozilla-central debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit mozilla-central debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit mozilla-central debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-1
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-2
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-3
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-4
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-5
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-1
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-2
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-3
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-4
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-5
+ Windows 7 32-bit mozilla-inbound debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit mozilla-inbound debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit mozilla-inbound debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-1
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-2
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-3
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-4
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-5
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-1
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-2
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-3
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-4
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-5
+ Windows 7 32-bit oak debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit oak debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit oak debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit oak opt test mochitest-e10s-1
+ Windows 7 32-bit oak opt test mochitest-e10s-2
+ Windows 7 32-bit oak opt test mochitest-e10s-3
+ Windows 7 32-bit oak opt test mochitest-e10s-4
+ Windows 7 32-bit oak opt test mochitest-e10s-5
+ Windows 7 32-bit try debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit try debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit try debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit try opt test mochitest-e10s-1
+ Windows 7 32-bit try opt test mochitest-e10s-2
+ Windows 7 32-bit try opt test mochitest-e10s-3
+ Windows 7 32-bit try opt test mochitest-e10s-4
+ Windows 7 32-bit try opt test mochitest-e10s-5
+ Windows 7 32-bit try pgo test mochitest-e10s-1
+ Windows 7 32-bit try pgo test mochitest-e10s-2
+ Windows 7 32-bit try pgo test mochitest-e10s-3
+ Windows 7 32-bit try pgo test mochitest-e10s-4
+ Windows 7 32-bit try pgo test mochitest-e10s-5
+ Windows XP 32-bit ash opt test mochitest-e10s-1
+ Windows XP 32-bit ash opt test mochitest-e10s-2
+ Windows XP 32-bit ash opt test mochitest-e10s-3
+ Windows XP 32-bit ash opt test mochitest-e10s-4
+ Windows XP 32-bit ash opt test mochitest-e10s-5
+ Windows XP 32-bit cedar opt test mochitest-e10s-1
+ Windows XP 32-bit cedar opt test mochitest-e10s-2
+ Windows XP 32-bit cedar opt test mochitest-e10s-3
+ Windows XP 32-bit cedar opt test mochitest-e10s-4
+ Windows XP 32-bit cedar opt test mochitest-e10s-5
+ Windows XP 32-bit cypress opt test mochitest-e10s-1
+ Windows XP 32-bit cypress opt test mochitest-e10s-2
+ Windows XP 32-bit cypress opt test mochitest-e10s-3
+ Windows XP 32-bit cypress opt test mochitest-e10s-4
+ Windows XP 32-bit cypress opt test mochitest-e10s-5
+ Windows XP 32-bit fig opt test mochitest-e10s-1
+ Windows XP 32-bit fig opt test mochitest-e10s-2
+ Windows XP 32-bit fig opt test mochitest-e10s-3
+ Windows XP 32-bit fig opt test mochitest-e10s-4
+ Windows XP 32-bit fig opt test mochitest-e10s-5
+ Windows XP 32-bit fx-team opt test mochitest-e10s-1
+ Windows XP 32-bit fx-team opt test mochitest-e10s-2
+ Windows XP 32-bit fx-team opt test mochitest-e10s-3
+ Windows XP 32-bit fx-team opt test mochitest-e10s-4
+ Windows XP 32-bit fx-team opt test mochitest-e10s-5
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-1
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-2
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-3
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-4
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-5
+ Windows XP 32-bit gum opt test mochitest-e10s-1
+ Windows XP 32-bit gum opt test mochitest-e10s-2
+ Windows XP 32-bit gum opt test mochitest-e10s-3
+ Windows XP 32-bit gum opt test mochitest-e10s-4
+ Windows XP 32-bit gum opt test mochitest-e10s-5
+ Windows XP 32-bit gum pgo test mochitest-e10s-1
+ Windows XP 32-bit gum pgo test mochitest-e10s-2
+ Windows XP 32-bit gum pgo test mochitest-e10s-3
+ Windows XP 32-bit gum pgo test mochitest-e10s-4
+ Windows XP 32-bit gum pgo test mochitest-e10s-5
+ Windows XP 32-bit jamun opt test mochitest-e10s-1
+ Windows XP 32-bit jamun opt test mochitest-e10s-2
+ Windows XP 32-bit jamun opt test mochitest-e10s-3
+ Windows XP 32-bit jamun opt test mochitest-e10s-4
+ Windows XP 32-bit jamun opt test mochitest-e10s-5
+ Windows XP 32-bit maple opt test mochitest-e10s-1
+ Windows XP 32-bit maple opt test mochitest-e10s-2
+ Windows XP 32-bit maple opt test mochitest-e10s-3
+ Windows XP 32-bit maple opt test mochitest-e10s-4
+ Windows XP 32-bit maple opt test mochitest-e10s-5
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-1
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-2
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-3
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-4
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-5
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-1
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-2
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-3
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-4
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-5
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-1
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-2
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-3
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-4
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-5
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-1
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-2
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-3
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-4
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-5
+ Windows XP 32-bit oak opt test mochitest-e10s-1
+ Windows XP 32-bit oak opt test mochitest-e10s-2
+ Windows XP 32-bit oak opt test mochitest-e10s-3
+ Windows XP 32-bit oak opt test mochitest-e10s-4
+ Windows XP 32-bit oak opt test mochitest-e10s-5
+ Windows XP 32-bit try opt test mochitest-e10s-1
+ Windows XP 32-bit try opt test mochitest-e10s-2
+ Windows XP 32-bit try opt test mochitest-e10s-3
+ Windows XP 32-bit try opt test mochitest-e10s-4
+ Windows XP 32-bit try opt test mochitest-e10s-5
+ Windows XP 32-bit try pgo test mochitest-e10s-1
+ Windows XP 32-bit try pgo test mochitest-e10s-2
+ Windows XP 32-bit try pgo test mochitest-e10s-3
+ Windows XP 32-bit try pgo test mochitest-e10s-4
+ Windows XP 32-bit try pgo test mochitest-e10s-5
I think we're still too capacity-constrained to be another 3 10.10 jobs to every push. And Windows 7 tests are also chronically backlogged these days. Are we going to give them the 10.10 treatment and make them non-default on Try at some point to help offset all this?

Comment 20

3 years ago
coop: we bought a lot of iX machines for the Android x86 projects and the Linux 64-bit hardware pool is under-utilized. Could we please re-purpose a bunch on Q2 as Windows testers?
Flags: needinfo?(coop)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #18)
> I think we're still too capacity-constrained to be another 3 10.10 jobs to
> every push. And Windows 7 tests are also chronically backlogged these days.
> Are we going to give them the 10.10 treatment and make them non-default on
> Try at some point to help offset all this?

I echo this sentiment.

AIUI, the goal is for e10s to be the default at some point. Is there a plan to turn off non-e10s testing at that point, and do we have a target gecko version for that yet?

(In reply to Armen Zambrano G. (:armenzg - Toronto) from comment #20)
> coop: we bought a lot of iX machines for the Android x86 projects and the
> Linux 64-bit hardware pool is under-utilized. Could we please re-purpose a
> bunch on Q2 as Windows testers?

Yes, we could probably reclaim some capacity there. I think we could safely move 30 machines from the talos-linux32-ix/talos-linux64-ix pools and still keep pace with the other platforms. 

If this is something you'd like us to do, please file a separate bug.
Flags: needinfo?(coop)
(Assignee)

Comment 22

3 years ago
(In reply to Chris Cooper [:coop] from comment #21)
> 
> AIUI, the goal is for e10s to be the default at some point. Is there a plan
> to turn off non-e10s testing at that point, and do we have a target gecko
> version for that yet?

It has been communicated to me that we'll need duel test coverage for the entire rollout since we don't want to get up to release and be without a well tested non-e10s escape path. That said, I think once we're on aurora, we could start disabling some non-e10s suites on mc.. once we're on beta we can disable more on mc and a few on aurora..

Comment 23

3 years ago
Comment on attachment 8588591 [details] [diff] [review]
buildbot configs

Review of attachment 8588591 [details] [diff] [review]:
-----------------------------------------------------------------

The patch looks good.
If you want win8 jobs, you will have to use 'win64' besides 'win32'.

Wrt to enable/disable by default on try I will have to defer to someone else to help out since I don't know how to manage per test suites.

IIUC we can:
* control per slave patform (http://hg.mozilla.org/build/buildbot-configs/file/default/mozilla-tests/config.py#l125)
* control talos jobs (http://hg.mozilla.org/build/buildbot-configs/file/default/mozilla-tests/config.py#l253)
Attachment #8588591 - Flags: review?(armenzg) → review+

Comment 24

3 years ago
As I recalled bug 1116275

Comment 25

3 years ago
I would like us to proceed with this as-is (without per suite selection for try) or have someone work on bug 1116275.
(Assignee)

Comment 26

3 years ago
Created attachment 8589048 [details] [diff] [review]
buildbot configs

adding 64-bit win8 to a couple test suites per comment 23.

Do we need to set up a meeting between the e10s team and releng to discuss the test slave problem? The number of tests and suites will continue to increase as we enable more suites and fix disabled tests. This slave exhaustion problem is going to get worse before it gets better..
Attachment #8588591 - Attachment is obsolete: true
Attachment #8589048 - Flags: review?(armenzg)

Comment 27

3 years ago
Comment on attachment 8589048 [details] [diff] [review]
buildbot configs

Review of attachment 8589048 [details] [diff] [review]:
-----------------------------------------------------------------

The patch lgtm.

I believe this week SETA is kicking in and we might have more throughput.
I've also filed bug 1151591 to re-balance the pools of machines.

With regards to your last comment I will let releng answer it.

Builders added:
+ Rev5 MacOSX Yosemite 10.10 ash debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 ash debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 ash debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 cedar debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 cedar debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 cedar debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 cypress debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 cypress debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 cypress debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 fig debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 fig debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 fig debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 fx-team debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 fx-team debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 fx-team debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 gum debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 gum debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 gum debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 jamun debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 jamun debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 jamun debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 maple debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 maple debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 maple debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 mozilla-central debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 mozilla-central debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 mozilla-central debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 oak debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 oak debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 oak debug test mochitest-e10s-browser-chrome-3
+ Rev5 MacOSX Yosemite 10.10 try debug test mochitest-e10s-browser-chrome-1
+ Rev5 MacOSX Yosemite 10.10 try debug test mochitest-e10s-browser-chrome-2
+ Rev5 MacOSX Yosemite 10.10 try debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit ash debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit ash debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit ash debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit ash opt test mochitest-e10s-1
+ Windows 7 32-bit ash opt test mochitest-e10s-2
+ Windows 7 32-bit ash opt test mochitest-e10s-3
+ Windows 7 32-bit ash opt test mochitest-e10s-4
+ Windows 7 32-bit ash opt test mochitest-e10s-5
+ Windows 7 32-bit b2g-inbound debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit b2g-inbound debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit b2g-inbound debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-1
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-2
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-3
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-4
+ Windows 7 32-bit b2g-inbound opt test mochitest-e10s-5
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-1
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-2
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-3
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-4
+ Windows 7 32-bit b2g-inbound pgo test mochitest-e10s-5
+ Windows 7 32-bit cedar debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit cedar debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit cedar debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit cedar opt test mochitest-e10s-1
+ Windows 7 32-bit cedar opt test mochitest-e10s-2
+ Windows 7 32-bit cedar opt test mochitest-e10s-3
+ Windows 7 32-bit cedar opt test mochitest-e10s-4
+ Windows 7 32-bit cedar opt test mochitest-e10s-5
+ Windows 7 32-bit cypress debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit cypress debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit cypress debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit cypress opt test mochitest-e10s-1
+ Windows 7 32-bit cypress opt test mochitest-e10s-2
+ Windows 7 32-bit cypress opt test mochitest-e10s-3
+ Windows 7 32-bit cypress opt test mochitest-e10s-4
+ Windows 7 32-bit cypress opt test mochitest-e10s-5
+ Windows 7 32-bit fig debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit fig debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit fig debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit fig opt test mochitest-e10s-1
+ Windows 7 32-bit fig opt test mochitest-e10s-2
+ Windows 7 32-bit fig opt test mochitest-e10s-3
+ Windows 7 32-bit fig opt test mochitest-e10s-4
+ Windows 7 32-bit fig opt test mochitest-e10s-5
+ Windows 7 32-bit fx-team debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit fx-team debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit fx-team debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit fx-team opt test mochitest-e10s-1
+ Windows 7 32-bit fx-team opt test mochitest-e10s-2
+ Windows 7 32-bit fx-team opt test mochitest-e10s-3
+ Windows 7 32-bit fx-team opt test mochitest-e10s-4
+ Windows 7 32-bit fx-team opt test mochitest-e10s-5
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-1
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-2
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-3
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-4
+ Windows 7 32-bit fx-team pgo test mochitest-e10s-5
+ Windows 7 32-bit gum debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit gum debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit gum debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit gum opt test mochitest-e10s-1
+ Windows 7 32-bit gum opt test mochitest-e10s-2
+ Windows 7 32-bit gum opt test mochitest-e10s-3
+ Windows 7 32-bit gum opt test mochitest-e10s-4
+ Windows 7 32-bit gum opt test mochitest-e10s-5
+ Windows 7 32-bit gum pgo test mochitest-e10s-1
+ Windows 7 32-bit gum pgo test mochitest-e10s-2
+ Windows 7 32-bit gum pgo test mochitest-e10s-3
+ Windows 7 32-bit gum pgo test mochitest-e10s-4
+ Windows 7 32-bit gum pgo test mochitest-e10s-5
+ Windows 7 32-bit jamun debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit jamun debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit jamun debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit jamun opt test mochitest-e10s-1
+ Windows 7 32-bit jamun opt test mochitest-e10s-2
+ Windows 7 32-bit jamun opt test mochitest-e10s-3
+ Windows 7 32-bit jamun opt test mochitest-e10s-4
+ Windows 7 32-bit jamun opt test mochitest-e10s-5
+ Windows 7 32-bit maple debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit maple debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit maple debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit maple opt test mochitest-e10s-1
+ Windows 7 32-bit maple opt test mochitest-e10s-2
+ Windows 7 32-bit maple opt test mochitest-e10s-3
+ Windows 7 32-bit maple opt test mochitest-e10s-4
+ Windows 7 32-bit maple opt test mochitest-e10s-5
+ Windows 7 32-bit mozilla-central debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit mozilla-central debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit mozilla-central debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-1
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-2
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-3
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-4
+ Windows 7 32-bit mozilla-central opt test mochitest-e10s-5
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-1
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-2
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-3
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-4
+ Windows 7 32-bit mozilla-central pgo test mochitest-e10s-5
+ Windows 7 32-bit mozilla-inbound debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit mozilla-inbound debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit mozilla-inbound debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-1
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-2
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-3
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-4
+ Windows 7 32-bit mozilla-inbound opt test mochitest-e10s-5
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-1
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-2
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-3
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-4
+ Windows 7 32-bit mozilla-inbound pgo test mochitest-e10s-5
+ Windows 7 32-bit oak debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit oak debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit oak debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit oak opt test mochitest-e10s-1
+ Windows 7 32-bit oak opt test mochitest-e10s-2
+ Windows 7 32-bit oak opt test mochitest-e10s-3
+ Windows 7 32-bit oak opt test mochitest-e10s-4
+ Windows 7 32-bit oak opt test mochitest-e10s-5
+ Windows 7 32-bit try debug test mochitest-e10s-browser-chrome-1
+ Windows 7 32-bit try debug test mochitest-e10s-browser-chrome-2
+ Windows 7 32-bit try debug test mochitest-e10s-browser-chrome-3
+ Windows 7 32-bit try opt test mochitest-e10s-1
+ Windows 7 32-bit try opt test mochitest-e10s-2
+ Windows 7 32-bit try opt test mochitest-e10s-3
+ Windows 7 32-bit try opt test mochitest-e10s-4
+ Windows 7 32-bit try opt test mochitest-e10s-5
+ Windows 7 32-bit try pgo test mochitest-e10s-1
+ Windows 7 32-bit try pgo test mochitest-e10s-2
+ Windows 7 32-bit try pgo test mochitest-e10s-3
+ Windows 7 32-bit try pgo test mochitest-e10s-4
+ Windows 7 32-bit try pgo test mochitest-e10s-5
+ Windows 8 64-bit ash opt test mochitest-e10s-1
+ Windows 8 64-bit ash opt test mochitest-e10s-2
+ Windows 8 64-bit ash opt test mochitest-e10s-3
+ Windows 8 64-bit ash opt test mochitest-e10s-4
+ Windows 8 64-bit ash opt test mochitest-e10s-5
+ Windows 8 64-bit b2g-inbound opt test mochitest-e10s-1
+ Windows 8 64-bit b2g-inbound opt test mochitest-e10s-2
+ Windows 8 64-bit b2g-inbound opt test mochitest-e10s-3
+ Windows 8 64-bit b2g-inbound opt test mochitest-e10s-4
+ Windows 8 64-bit b2g-inbound opt test mochitest-e10s-5
+ Windows 8 64-bit b2g-inbound pgo test mochitest-e10s-1
+ Windows 8 64-bit b2g-inbound pgo test mochitest-e10s-2
+ Windows 8 64-bit b2g-inbound pgo test mochitest-e10s-3
+ Windows 8 64-bit b2g-inbound pgo test mochitest-e10s-4
+ Windows 8 64-bit b2g-inbound pgo test mochitest-e10s-5
+ Windows 8 64-bit cedar opt test mochitest-e10s-1
+ Windows 8 64-bit cedar opt test mochitest-e10s-2
+ Windows 8 64-bit cedar opt test mochitest-e10s-3
+ Windows 8 64-bit cedar opt test mochitest-e10s-4
+ Windows 8 64-bit cedar opt test mochitest-e10s-5
+ Windows 8 64-bit cypress opt test mochitest-e10s-1
+ Windows 8 64-bit cypress opt test mochitest-e10s-2
+ Windows 8 64-bit cypress opt test mochitest-e10s-3
+ Windows 8 64-bit cypress opt test mochitest-e10s-4
+ Windows 8 64-bit cypress opt test mochitest-e10s-5
+ Windows 8 64-bit fig opt test mochitest-e10s-1
+ Windows 8 64-bit fig opt test mochitest-e10s-2
+ Windows 8 64-bit fig opt test mochitest-e10s-3
+ Windows 8 64-bit fig opt test mochitest-e10s-4
+ Windows 8 64-bit fig opt test mochitest-e10s-5
+ Windows 8 64-bit fx-team opt test mochitest-e10s-1
+ Windows 8 64-bit fx-team opt test mochitest-e10s-2
+ Windows 8 64-bit fx-team opt test mochitest-e10s-3
+ Windows 8 64-bit fx-team opt test mochitest-e10s-4
+ Windows 8 64-bit fx-team opt test mochitest-e10s-5
+ Windows 8 64-bit fx-team pgo test mochitest-e10s-1
+ Windows 8 64-bit fx-team pgo test mochitest-e10s-2
+ Windows 8 64-bit fx-team pgo test mochitest-e10s-3
+ Windows 8 64-bit fx-team pgo test mochitest-e10s-4
+ Windows 8 64-bit fx-team pgo test mochitest-e10s-5
+ Windows 8 64-bit gum opt test mochitest-e10s-1
+ Windows 8 64-bit gum opt test mochitest-e10s-2
+ Windows 8 64-bit gum opt test mochitest-e10s-3
+ Windows 8 64-bit gum opt test mochitest-e10s-4
+ Windows 8 64-bit gum opt test mochitest-e10s-5
+ Windows 8 64-bit gum pgo test mochitest-e10s-1
+ Windows 8 64-bit gum pgo test mochitest-e10s-2
+ Windows 8 64-bit gum pgo test mochitest-e10s-3
+ Windows 8 64-bit gum pgo test mochitest-e10s-4
+ Windows 8 64-bit gum pgo test mochitest-e10s-5
+ Windows 8 64-bit jamun opt test mochitest-e10s-1
+ Windows 8 64-bit jamun opt test mochitest-e10s-2
+ Windows 8 64-bit jamun opt test mochitest-e10s-3
+ Windows 8 64-bit jamun opt test mochitest-e10s-4
+ Windows 8 64-bit jamun opt test mochitest-e10s-5
+ Windows 8 64-bit maple opt test mochitest-e10s-1
+ Windows 8 64-bit maple opt test mochitest-e10s-2
+ Windows 8 64-bit maple opt test mochitest-e10s-3
+ Windows 8 64-bit maple opt test mochitest-e10s-4
+ Windows 8 64-bit maple opt test mochitest-e10s-5
+ Windows 8 64-bit mozilla-central opt test mochitest-e10s-1
+ Windows 8 64-bit mozilla-central opt test mochitest-e10s-2
+ Windows 8 64-bit mozilla-central opt test mochitest-e10s-3
+ Windows 8 64-bit mozilla-central opt test mochitest-e10s-4
+ Windows 8 64-bit mozilla-central opt test mochitest-e10s-5
+ Windows 8 64-bit mozilla-central pgo test mochitest-e10s-1
+ Windows 8 64-bit mozilla-central pgo test mochitest-e10s-2
+ Windows 8 64-bit mozilla-central pgo test mochitest-e10s-3
+ Windows 8 64-bit mozilla-central pgo test mochitest-e10s-4
+ Windows 8 64-bit mozilla-central pgo test mochitest-e10s-5
+ Windows 8 64-bit mozilla-inbound opt test mochitest-e10s-1
+ Windows 8 64-bit mozilla-inbound opt test mochitest-e10s-2
+ Windows 8 64-bit mozilla-inbound opt test mochitest-e10s-3
+ Windows 8 64-bit mozilla-inbound opt test mochitest-e10s-4
+ Windows 8 64-bit mozilla-inbound opt test mochitest-e10s-5
+ Windows 8 64-bit mozilla-inbound pgo test mochitest-e10s-1
+ Windows 8 64-bit mozilla-inbound pgo test mochitest-e10s-2
+ Windows 8 64-bit mozilla-inbound pgo test mochitest-e10s-3
+ Windows 8 64-bit mozilla-inbound pgo test mochitest-e10s-4
+ Windows 8 64-bit mozilla-inbound pgo test mochitest-e10s-5
+ Windows 8 64-bit oak opt test mochitest-e10s-1
+ Windows 8 64-bit oak opt test mochitest-e10s-2
+ Windows 8 64-bit oak opt test mochitest-e10s-3
+ Windows 8 64-bit oak opt test mochitest-e10s-4
+ Windows 8 64-bit oak opt test mochitest-e10s-5
+ Windows 8 64-bit try opt test mochitest-e10s-1
+ Windows 8 64-bit try opt test mochitest-e10s-2
+ Windows 8 64-bit try opt test mochitest-e10s-3
+ Windows 8 64-bit try opt test mochitest-e10s-4
+ Windows 8 64-bit try opt test mochitest-e10s-5
+ Windows 8 64-bit try pgo test mochitest-e10s-1
+ Windows 8 64-bit try pgo test mochitest-e10s-2
+ Windows 8 64-bit try pgo test mochitest-e10s-3
+ Windows 8 64-bit try pgo test mochitest-e10s-4
+ Windows 8 64-bit try pgo test mochitest-e10s-5
+ Windows XP 32-bit ash opt test mochitest-e10s-1
+ Windows XP 32-bit ash opt test mochitest-e10s-2
+ Windows XP 32-bit ash opt test mochitest-e10s-3
+ Windows XP 32-bit ash opt test mochitest-e10s-4
+ Windows XP 32-bit ash opt test mochitest-e10s-5
+ Windows XP 32-bit cedar opt test mochitest-e10s-1
+ Windows XP 32-bit cedar opt test mochitest-e10s-2
+ Windows XP 32-bit cedar opt test mochitest-e10s-3
+ Windows XP 32-bit cedar opt test mochitest-e10s-4
+ Windows XP 32-bit cedar opt test mochitest-e10s-5
+ Windows XP 32-bit cypress opt test mochitest-e10s-1
+ Windows XP 32-bit cypress opt test mochitest-e10s-2
+ Windows XP 32-bit cypress opt test mochitest-e10s-3
+ Windows XP 32-bit cypress opt test mochitest-e10s-4
+ Windows XP 32-bit cypress opt test mochitest-e10s-5
+ Windows XP 32-bit fig opt test mochitest-e10s-1
+ Windows XP 32-bit fig opt test mochitest-e10s-2
+ Windows XP 32-bit fig opt test mochitest-e10s-3
+ Windows XP 32-bit fig opt test mochitest-e10s-4
+ Windows XP 32-bit fig opt test mochitest-e10s-5
+ Windows XP 32-bit fx-team opt test mochitest-e10s-1
+ Windows XP 32-bit fx-team opt test mochitest-e10s-2
+ Windows XP 32-bit fx-team opt test mochitest-e10s-3
+ Windows XP 32-bit fx-team opt test mochitest-e10s-4
+ Windows XP 32-bit fx-team opt test mochitest-e10s-5
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-1
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-2
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-3
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-4
+ Windows XP 32-bit fx-team pgo test mochitest-e10s-5
+ Windows XP 32-bit gum opt test mochitest-e10s-1
+ Windows XP 32-bit gum opt test mochitest-e10s-2
+ Windows XP 32-bit gum opt test mochitest-e10s-3
+ Windows XP 32-bit gum opt test mochitest-e10s-4
+ Windows XP 32-bit gum opt test mochitest-e10s-5
+ Windows XP 32-bit gum pgo test mochitest-e10s-1
+ Windows XP 32-bit gum pgo test mochitest-e10s-2
+ Windows XP 32-bit gum pgo test mochitest-e10s-3
+ Windows XP 32-bit gum pgo test mochitest-e10s-4
+ Windows XP 32-bit gum pgo test mochitest-e10s-5
+ Windows XP 32-bit jamun opt test mochitest-e10s-1
+ Windows XP 32-bit jamun opt test mochitest-e10s-2
+ Windows XP 32-bit jamun opt test mochitest-e10s-3
+ Windows XP 32-bit jamun opt test mochitest-e10s-4
+ Windows XP 32-bit jamun opt test mochitest-e10s-5
+ Windows XP 32-bit maple opt test mochitest-e10s-1
+ Windows XP 32-bit maple opt test mochitest-e10s-2
+ Windows XP 32-bit maple opt test mochitest-e10s-3
+ Windows XP 32-bit maple opt test mochitest-e10s-4
+ Windows XP 32-bit maple opt test mochitest-e10s-5
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-1
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-2
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-3
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-4
+ Windows XP 32-bit mozilla-central opt test mochitest-e10s-5
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-1
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-2
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-3
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-4
+ Windows XP 32-bit mozilla-central pgo test mochitest-e10s-5
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-1
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-2
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-3
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-4
+ Windows XP 32-bit mozilla-inbound opt test mochitest-e10s-5
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-1
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-2
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-3
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-4
+ Windows XP 32-bit mozilla-inbound pgo test mochitest-e10s-5
+ Windows XP 32-bit oak opt test mochitest-e10s-1
+ Windows XP 32-bit oak opt test mochitest-e10s-2
+ Windows XP 32-bit oak opt test mochitest-e10s-3
+ Windows XP 32-bit oak opt test mochitest-e10s-4
+ Windows XP 32-bit oak opt test mochitest-e10s-5
+ Windows XP 32-bit try opt test mochitest-e10s-1
+ Windows XP 32-bit try opt test mochitest-e10s-2
+ Windows XP 32-bit try opt test mochitest-e10s-3
+ Windows XP 32-bit try opt test mochitest-e10s-4
+ Windows XP 32-bit try opt test mochitest-e10s-5
+ Windows XP 32-bit try pgo test mochitest-e10s-1
+ Windows XP 32-bit try pgo test mochitest-e10s-2
+ Windows XP 32-bit try pgo test mochitest-e10s-3
+ Windows XP 32-bit try pgo test mochitest-e10s-4
+ Windows XP 32-bit try pgo test mochitest-e10s-5
Attachment #8589048 - Flags: review?(armenzg) → review+
(Assignee)

Comment 28

3 years ago
So is this bug waiting on me, or maybe we still need to sort out the slave issues? If there are bugs we're blocked on please connect them up here.

Comment 29

3 years ago
I think we should go ahead and land this.
I don't think we should slow you down after putting effort to green things up.

I filed bug 1151591 to rebalance the pools if anyone would like to drive that to completion.
(Assignee)

Comment 30

3 years ago
(In reply to Armen Zambrano G. (:armenzg - Toronto) from comment #29)
> I think we should go ahead and land this.
> I don't think we should slow you down after putting effort to green things
> up.
> 
> I filed bug 1151591 to rebalance the pools if anyone would like to drive
> that to completion.

Hey Armen, what's the procedure today on this, do I land this work on mc now? In the past we had to do pre-production testing and such, and releng generally ran that internally. Then patches had to land somewhere outside of mc.
Flags: needinfo?(armenzg)

Comment 31

3 years ago
(In reply to Jim Mathies [:jimm] from comment #30)
> (In reply to Armen Zambrano G. (:armenzg - Toronto) from comment #29)
> > I think we should go ahead and land this.
> > I don't think we should slow you down after putting effort to green things
> > up.
> > 
> > I filed bug 1151591 to rebalance the pools if anyone would like to drive
> > that to completion.
> 
> Hey Armen, what's the procedure today on this, do I land this work on mc
> now? In the past we had to do pre-production testing and such, and releng
> generally ran that internally. Then patches had to land somewhere outside of
> mc.

Let me see if I understand.
You have some patches for the work of e10s on the Holly repo.
You need them to land on mc.
You need some jobs to make sure you work does not get regressed.

If you push your code to try, does any of the current jobs get affected?
If not, can you land it on mozilla-inbound?

Wrt to the releng code, I believe we should land it once your code has landed on m-i, merged to m-c and left there for a day.
By doing this way, we can sure that when the jobs first appear on the integration branches, they will show up as green (hopefully).

An by pre-production, I think you mean the "default" branch of buildbot-configs and by running it internally I think you refer to running "buildbot reconfig", which is simply the command needed to update the scheduling based on the buildbot-configs on the "production" branch.

In other words, if you're ready on your side, you could start landing on m-i.
Flags: needinfo?(armenzg)
(Assignee)

Comment 32

3 years ago
> > Hey Armen, what's the procedure today on this, do I land this work on mc
> > now? In the past we had to do pre-production testing and such, and releng
> > generally ran that internally. Then patches had to land somewhere outside of
> > mc.
> 
> Let me see if I understand.
> You have some patches for the work of e10s on the Holly repo.
> You need them to land on mc.
> You need some jobs to make sure you work does not get regressed.

I just want to turn on additional tests on mc. The patch posted here is from the buildbot-config folder under the build repo. Not sure If I should land that?
Flags: needinfo?(armenzg)

Comment 33

3 years ago
(In reply to Jim Mathies [:jimm] from comment #32)
> > > Hey Armen, what's the procedure today on this, do I land this work on mc
> > > now? In the past we had to do pre-production testing and such, and releng
> > > generally ran that internally. Then patches had to land somewhere outside of
> > > mc.
> > 
> > Let me see if I understand.
> > You have some patches for the work of e10s on the Holly repo.
> > You need them to land on mc.
> > You need some jobs to make sure you work does not get regressed.
> 
> I just want to turn on additional tests on mc. The patch posted here is from
> the buildbot-config folder under the build repo. Not sure If I should land
> that?

If you don't need to land any patches from Holly on m-c for these new jobs to show up green on TH go ahead and land the buildbot configs.

Here's the visibility policy in case you need to check that we are meeting all expectations:
https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy
Flags: needinfo?(armenzg)
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215233
You need to log in before you can comment on or make changes to this bug.