If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crashes when scrolling the page to a certain area

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: SasQ, Unassigned)

Tracking

({crash})

30 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.16

Steps to reproduce:

1. Go to the website http://mlpforums.com/
2. Wait for the page to load fully (just to make sure that it doesn't crash during page load).
3. Carefully scroll the page down.


Actual results:

The whole browser crashes immediately and ungracefully after crossing the "CHARITY" heading.

When I run it through GNU Debugger (gdb) and print the backtrace after the crash, I see that it crashes somewhere below calling cairo_fill_preserve() from /usr/lib64/libcairo.so.2 . The call subtree is 9 levels deeper into the Cairo library, but the function names are not shown, only addresses (consistent between subsequent runs). The cairo_fill_preserve has been called direcly from 0x00007ffff418ff0a in ?? () from /usr/lib64/firefox/libxul.so . This function's address is also consistent between subsequent runs.

The bug is reproducible always.

I also tried switching off Flash loading, just to make sure it doesn't crash from the Flash plugin, but it didn't change anything, so the bug doesn't seem to be plugin-related.


Expected results:

No crash, correct scrolling.
(Reporter)

Comment 1

3 years ago
I tested it on other subpages of this forum and it seems to crash every time that brown bar with custom font comes into view. So it might be related with handling CSS custom fonts, or this particular font.

Comment 2

3 years ago
Can you use an official build from https://www.mozilla.org, and if that still crashes, go to about:crashes to post a crash report ID? Then instead of having addresses, we can get a proper stack trace. Thank you!
Severity: normal → critical
Flags: needinfo?(sasq1)
Keywords: crash

Comment 3

3 years ago
tried all the steps could not re produce
(Reporter)

Comment 4

3 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> Can you use an official build from https://www.mozilla.org, and if that
> still crashes, go to about:crashes to post a crash report ID? Then instead
> of having addresses, we can get a proper stack trace. Thank you!

Yes, I can. I've just did it, and it doesn't crash.

When I find some time, I'll try to recompile that version which crashes with the "debug" USE flag turned on and see if I can get any more detailed information from the backtrace.

But judging by the last comment, I don't know if it's really worth my time, since I can pretty much see where it's going...
Flags: needinfo?(sasq1)
Unable to reproduce on 45.0a1 (2015-12-14), Ubuntu 14.04. 
Please upgrade Firefox and reopen if you still reproduce the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.