Default Search Engine reverted to Yahoo upon update after it was re-set to Google

RESOLVED DUPLICATE of bug 1121252

Status

()

RESOLVED DUPLICATE of bug 1121252
4 years ago
4 years ago

People

(Reporter: hibbard.tyler, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I updated to Firefox 34, where the default search engine was changed from Google to Yahoo. I had to re-set the default search engine to Google, and I removed all other engines from the suggestions or the dropdown list.


Actual results:

Upon updating to Firefox 35, the search engine had once again reverted to Yahoo, even though I unchecked it and had previously selected Google as my search engine, and removed all other search engines from the suggestions list.


Expected results:

Once a user sets a default search engine, it should *never* be changed by the browser, even on version update. If settings revert to default after every automatic and unpreventable update, then you have a serious bug. The engine should not have even been switched to Yahoo in Firefox 34, even though it became the default; user-set preferences should have remained. Always opt-in, never opt-out.mozilla.
Component: Untriaged → Search
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121252
You need to log in before you can comment on or make changes to this bug.