Embeded flash ad robs keyboard focus from page

VERIFIED DUPLICATE of bug 78414

Status

()

Core
Keyboard: Navigation
--
minor
VERIFIED DUPLICATE of bug 78414
16 years ago
16 years ago

People

(Reporter: Wayne Davison, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    20011112009

I noticed while reading an article over on tomshardware.com that when I clicked
a link to the next page, I couldn't use the keypad to scroll the page.

Reproducible: Almost Always

Steps to Reproduce:

1. Visit any article link on tomshardware.com such as the URL provided above. 
(Don't use the front page because that gives you two ad banners, making it
harder to get a page without any flash.)

2. Try to scroll the page with the keypad (hit down-arrow or page-down).  If
scrolling fails, the ad will be a embedded flash object (you can right-click it
to make sure).  [FYI: In this mode, pressing the tab key puts the focus into URL
box.]

3. To try to find a non-flash-ad page, either click the next-page link or FIRST
click somewhere in the page (to put the focus back where it should be -- on the
page) and then reload.  When you get an image ad, the keypad will scroll the
window just fine.  Note that if you fail to click somewhere in the window before
doing a reload and then get an image ad, the focus will still be off someplace
weird (i.e. no keypad scrolling will work -- Mozilla appears to maintain this
off-page focus when using the reload button).

Actual Results:  When an embedded flash ad is present, you have to click in the
window to use keypad scrolling.

Expected Results:  Going from page to page should let you scroll with the keypad
without having to click first.

Comment 1

16 years ago
dup of bug 78414?
sure looks like it!

*** This bug has been marked as a duplicate of 78414 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.