pagemod does not work in add-on

RESOLVED DUPLICATE of bug 1123295

Status

()

RESOLVED DUPLICATE of bug 1123295
4 years ago
13 days ago

People

(Reporter: ssk97, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8550847 [details]
Example add-on that should replace .org webpages

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I had previously been using an add-on, and found that it was no longer working. Upon investigation, I found a minimal test case for failure:
1) Create an add-on using the first example code here: https://developer.mozilla.org/en-US/Add-ons/SDK/Tutorials/Modifying_Web_Pages_Based_on_URL
2) cfx run the addon w/ adb
2b) Alternatively, install the addon from an xpi file

I am using Android 4.4.2 on a Moto G.


Actual results:

Mozilla.org and Wikipedia.org loaded normally on Firefox Beta (36) and on Nightly (38.0a1).


Expected results:

Page should be replaced once it's finished loading and the pagemod is applied. Works as expected on Firefox (35) and on desktop firefox/nightly installation.
Is this an add-on SDK issue or something that we don't support that we should implement?
Flags: needinfo?(margaret.leibovic)

Comment 2

4 years ago
Without digging into the code, I'm not sure what would have regressed this.

Erik, has something changed with the add-on SDK that we should update for Fennec?
Flags: needinfo?(margaret.leibovic) → needinfo?(evold)
(In reply to :Margaret Leibovic from comment #2)
> Without digging into the code, I'm not sure what would have regressed this.
> 
> Erik, has something changed with the add-on SDK that we should update for
> Fennec?

I'm not sure, we have previously noticed Fennec test issues, and decided that we need support/priority/interest from Fennec/Platform teams before spending more time on Fennec issues (ref https://wiki.mozilla.org/Jetpack/Weekly_Meeting/2014-05-06), for instance we need to resolve bug 809143.
Flags: needinfo?(evold)

Comment 4

4 years ago
Page Mod working fine in 34.0 and I am also facing same problem in latest firefox. I have google'd and noted that it's not working due to following bug
https://bugzilla.mozilla.org/show_bug.cgi?id=1123295

Can someone fix it.

Comment 5

13 days ago
Hi,

Does this issue still reproduce?

Thanks!
Flags: needinfo?(ssk97)
(Reporter)

Comment 6

13 days ago
This was fixed, it was a duplicate with https://bugzilla.mozilla.org/show_bug.cgi?id=1123295 (though really that was the duplicate if you look at the dates...)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Flags: needinfo?(ssk97)
Resolution: --- → DUPLICATE
Duplicate of bug: 1123295
You need to log in before you can comment on or make changes to this bug.