national characters from a google agenda incorrectly displayed in Thunderbird/lighning

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: POUILLOUX, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

google calendar synchronization with Thunderbird/Lightning using  "Fournisseur pour Google Agenda 1.0.3"


Actual results:

after synchronizing with Google, national characters from a Google agenda are not correctly displayed in Thunderbird/lightning


Expected results:

correct display of national characters after synchronizing a google agenda using  "Fournisseur pour Google Agenda 1.0.3"
Thanks for filing this bug. I doubt we can do anything on l10n side, so I'm moving the bug to Calendar.

Also, a screenshot of the issue might help.
Assignee: bugzilla.fr → nobody
Component: fr / French → General
Product: Mozilla Localizations → Calendar
QA Contact: benoit.leseul
Component: General → Provider: GData
(Reporter)

Comment 2

4 years ago
Created attachment 8551202 [details]
copy of lightning screen with incorrecly  displayed "noël"
How did this event get in your calendar? I tried the following and it works for me:

1) Go to google web interface
2) Create an event with title "noël"
3) Go to Lightning, synchronize

4) Create an event with Lightning, name it "noël"
5) Go back to Google web interface
6) Check if encoding is correct

I suspect the event may have been created by a different client that has character encoding issues. Is this an invitation event you can't control? If not, could you try renaming the event to see if that fixes it?

I'm going to close this WORKSFORME for now, but I'm happy to discuss further.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

4 years ago
Created attachment 8561990 [details]
"noël"incorrectly displayed in one agenda and correctly  displayed in the second one

Hi Philipp,

   Thanks for taking the problem into condideration.
   The national characters incorrectly displayed in Lightning are coming from a french general purpose agenda provided by Google and named: Calendrier scolaire zone "A"
   Surprisingly, in another general purpose agenda provided by Google "jours fériés", the french national characters are correctly displayed (see attachment).
   Maybe the problem is Google related and not with Ligthning.
Best Regards,
Daniel
Is the calendar Calendrier scolaire zone "A" public, i.e. can you paste a link to the calendar? I highly suspect this is an issue with the calendar.
(Reporter)

Comment 6

4 years ago
Thanks for your answer.

The 'Calendrier scolaire zone "A"' is a Google general purpose public agenda.
As requested, the corresponding link is: googleapi://daniel.pouilloux@gmail.com?calendar=e307ql6pmn8n4tk2318591empv0oioj5%40import.calendar.google.com

Hope it can help for a solution,
Regards,
Daniel
This looks like an imported calendar. I've checked the calendar and indeed the characters are just imported wrong. Therefore its an issue with the calendar that I can't sensibly do anything about. Google may be doing some character set detection, but I think that should rather be solved in Lightning, if at all. Thank you for the information on the calendar!
You need to log in before you can comment on or make changes to this bug.