Closed Bug 1123383 Opened 9 years ago Closed 9 years ago

SIMD (interpreter): remove Clamp

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: ProgramFOX, Assigned: ProgramFOX)

References

Details

(Keywords: dev-doc-complete, Whiteboard: [DocArea=JS])

Attachments

(1 file, 2 obsolete files)

Attached patch Patch - Removed Clamp (obsolete) — Splinter Review
Proposed patch that removes Clamp.
Attachment #8551380 - Flags: review?(benj)
Whoops, nevermind; I just noticed that Clamp got re-added [0]. Marking this as invalid.

[0]: https://github.com/johnmccutchan/ecmascript_simd/commit/6751101cd09bb3e60e548ab32f05f5e6090fc4b1
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Attachment #8551380 - Flags: review?(benj)
Reopening this bug because Clamp got removed again:
https://github.com/johnmccutchan/ecmascript_simd/commit/901b6c7d5a54136e447cec36a8821176db5c423c
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Keywords: dev-doc-needed
Whiteboard: [DocArea=JS]
Comment on attachment 8551380 [details] [diff] [review]
Patch - Removed Clamp

Review of attachment 8551380 [details] [diff] [review]:
-----------------------------------------------------------------

Hey ProgramFOX,
Just realized this was on my todo-list, but actually you already have a patch, so let's move it forward! r=me on the rebased patch (there shouldn't be a lot to change). Can you please rebase it, send it to the try server (on a separate try run), so that we can land it? Thanks!
Attachment #8551380 - Flags: review+
See comment 4
Flags: needinfo?(programfox)
Sure, I'll rebase it as soon as bug 1124291 is landed (so I only have to rebase it once).
Flags: needinfo?(programfox)
Assignee: nobody → programfox
Attached patch SIMD (interpreter): remove Clamp (obsolete) — Splinter Review
Rebased patch.

Try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b53c2153817c
Attachment #8551380 - Attachment is obsolete: true
Attachment #8631514 - Flags: review+
Try returned all green, adding checkin-needed.
Keywords: checkin-needed
sorry this failed to apply:

patching file js/src/builtin/SIMD.cpp
Hunk #1 FAILED at 1103
1 out of 1 hunks FAILED -- saving rejects to file js/src/builtin/SIMD.cpp.rej
patching file js/src/builtin/SIMD.h
Hunk #1 FAILED at 55
Hunk #2 FAILED at 108
2 out of 2 hunks FAILED -- saving rejects to file js/src/builtin/SIMD.h.rej
patching file js/src/tests/ecma_7/SIMD/clamp.js
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file js/src/tests/ecma_7/SIMD/clamp.js.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory


can you take a look, thanks!
Flags: needinfo?(programfox)
Keywords: checkin-needed
Ah, yup, it looks like I have to rebase my patch. I'm working on it.
Flags: needinfo?(programfox)
Rebased patch.

Try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ee7f479748fb
Attachment #8631514 - Attachment is obsolete: true
Attachment #8632464 - Flags: review+
After retriggering J3 on Android (an exception occurred), all tests passed, adding checkin-needed.
Keywords: checkin-needed
sorry had to back this out seems this caused https://treeherder.mozilla.org/logviewer.html#?job_id=11613830&repo=mozilla-inbound
Flags: needinfo?(programfox)
Hmm... I have no idea... it didn't happen on try either.

Pulsebot posted here that my patch got pushed again; does this mean that the errors were caused by another patch, or do I still have to take a closer look at it?
Flags: needinfo?(cbook)
Your patch wasn't at fault and I relanded it.
Flags: needinfo?(programfox)
Flags: needinfo?(cbook)
https://hg.mozilla.org/mozilla-central/rev/4c79f19db872
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Removed from MDN docs.
You need to log in before you can comment on or make changes to this bug.