Failing to load larger images in some circumstances

RESOLVED DUPLICATE of bug 1122845

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1122845
4 years ago
4 years ago

People

(Reporter: raff, Unassigned)

Tracking

33 Branch
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8551384 [details]
product_1852.JPG - an image to use for the test.

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.99 Safari/537.36

Steps to reproduce:

On a simple web page, use the following JavaScript
(you will need to change the path to some larger image online somewhere):


                    var img = new Image();
                    img.style.position = 'fixed';               
                    document.body.appendChild(img);                    
                    img.src = "path/to/a/large/image.jpg";

Clear the browser cache first to ensure the images are no cached.


Actual results:

Image is only partially loaded e.g. maybe only the first 200 pixels in height, but the rest is missing.


Expected results:

Image is fully loaded as it does on all the other browsers.

Comment 1

4 years ago
Can you try https://beta.mozilla.org/, please? I believe the issue you're referring to is the same as bug 1122845 which is fixed on Firefox 36 and later (currently in beta).
Flags: needinfo?(raff)
(Reporter)

Comment 2

4 years ago
Yes, this seems to be a duplicate of 1122845.

My test cases work correctly in FF36 beta.

Any work arounds until FF36 is released?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122845

Comment 3

4 years ago
BETA moves to RELEASE week of February 24, 2015.

Updated

4 years ago
Flags: needinfo?(raff)

Comment 4

4 years ago
(In reply to raff from comment #2)
> Any work arounds until FF36 is released?

I don't know, and bug 1098958 doesn't have any clues, sadly - apart from including images in the CSS as data URIs, but that's not really doable for big images... :-(
You need to log in before you can comment on or make changes to this bug.