Reader Mode should apply user defined style settings

RESOLVED DUPLICATE of bug 1126481

Status

()

Firefox for iOS
Reader View
RESOLVED DUPLICATE of bug 1126481
4 years ago
3 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This includes font face & size. And the theme (light, dark, sepia?)

The original CSS in aboutReader.css has all the content set to invisible. This was probably done to minimize flickering when the readerized content is loaded in it and the user defined settings (font face/size/theme) are applied.

We can keep this but it means that the ReaderMode.swift needs a page loaded callback so that we can apply the user style and make the document visible. Need to experiment because ideally we go from original page to readerized page really quickly without seeing any noticable delay or flickering or changes in content.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126481
You need to log in before you can comment on or make changes to this bug.