Stop using about:something style URLs

RESOLVED DUPLICATE of bug 1137051

Status

()

RESOLVED DUPLICATE of bug 1137051
4 years ago
4 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(fennec+)

Details

(Reporter)

Description

4 years ago
It seems NSURL cannot parse about:something style URLs such as about:reader?url=... This is a problem because it means we are feeding invalid URLs to a number of APIs such as webView.loadHTMLString() which could result in undefined behaviour.

As an alternative we could use something like about://reader?url=...

Updated

4 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → +
Could we inspect the URLs ahead of time (that is, before turning NSStrings into NSURLs), and handle them independently if they're about:something?

I ask this having not even looked at the code (but having implemented a very simple WebKit-based browser in the past in iOS).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137051
You need to log in before you can comment on or make changes to this bug.