We need to implement the WKUIDelegate to get popup, window and alert support

RESOLVED DUPLICATE of bug 1123501

Status

()

Firefox for iOS
Browser
RESOLVED DUPLICATE of bug 1123501
4 years ago
4 years ago

People

(Reporter: st3fan, Assigned: bnicholson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We need to implement the WKUIDelegate to support the following things:

* Allow pages to be opened in a popup with window.open()
* Allow pages to be opened in a new document with target="_blank"
* Allow pages to show dialogs via window.alert/confirm/prompt()

This is the reason the Yahoo search results page doesn' work: they open individual results with target="_blank". See bug 1123501

It is also the reason why some links from reader mode don't work. See bug 1123402
(Assignee)

Updated

4 years ago
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123501
(Assignee)

Updated

4 years ago
No longer blocks: 1123501
You need to log in before you can comment on or make changes to this bug.