Element with overflow:hidden not rendered properly when moved by Javascript

RESOLVED DUPLICATE of bug 1124543

Status

()

RESOLVED DUPLICATE of bug 1124543
4 years ago
3 years ago

People

(Reporter: suchiu, Unassigned)

Tracking

({regression})

Other Branch
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8551559 [details]
animation_bug.zip

Version: Nightly 38.0a1 (2015-01-18)
When the element and it's parent element move together by using Javascript, and the parent has overflow:hidden property, the rendered result is distorted.

Please try the attached sample html, the bug can be reproduced by commenting the following three lines in animation.js: 

maskElement.style.visibility = 'hidden';
window.getComputedStyle(maskElement).visibility;
...
...
maskElement.style.visibility = 'visible';

Updated

4 years ago
Component: DOM → Layout
I'm not seeing an obvious issue if I comment those three lines out.  In particular, the behavior is the same as with the lines _not_ commented out.  At least on Mac.

Is there more to reproducing this than just loading the index.html in that zip file?
Flags: needinfo?(suchiu)
(Reporter)

Comment 2

4 years ago
Created attachment 8552787 [details]
Recorded video of the bug

Hi, I'm able to reproduce it on many of my coworker's Mac here. The bug happens at 00:10 in attached video. Maybe you need to use Nightly or make the browser window bigger since it happens on the right side of a screen. Let me know if you need more information.
Flags: needinfo?(suchiu)
Ah, I see, yeah, I have to use a totally non-default window size.  Then I see it.  Seems to happen in Firefox 35 as well, and aurora and beta.

But does NOT happen in Firefox 34.

alice0775, are you willing to hunt down the regression range?
Flags: needinfo?(alice0775)
Keywords: regression, regressionwindow-wanted

Comment 4

4 years ago
(In reply to Boris Zbarsky [:bz] from comment #3)
> Ah, I see, yeah, I have to use a totally non-default window size.  Then I
> see it.  Seems to happen in Firefox 35 as well, and aurora and beta.
> 
> But does NOT happen in Firefox 34.
> 
> alice0775, are you willing to hunt down the regression range?

I can't test because I don't have  a high-resolution monitor.
Flags: needinfo?(alice0775)

Comment 5

4 years ago
However, I can notice a different glitch from the video(attachment 8552787 [details]) on Linux and Windows.
I am not sure this is a same cause or not.
So, I filed a new bug Bug 1124543 anyway.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124543
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.