[Media Storage] Media Storage does not show "Format SD card" button when inserted a unreadable SD card unless plug and unplug USB cable

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
Last year

People

(Reporter: ashiue, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/64dfa07e8913
Build-ID        20150119161205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.195738
FW-Date         Mon Jan 19 19:57:49 EST 2015
Bootloader      L1TC00011880


STR:
1. Inserted an unreadable SD card
2. Flash 2.1 build
3. Go to Settings -> Media storage

Expected result:
"Format SD card" button exists

Actual result:
"Format SD card" button does not exist unless plug and unplug USB cable
QA Whiteboard: [COM=Storage]
The root cause is that volume status changing sequence during booting is finished before we add an observer on volume status changing event. The problem flow is as following

1. while booting, initialize volumes status and try to mount them
   volume status changed: nomedia->pending->idle->checking->idle
2. add observer on volume status changing event
   system app can not check sdcard's unrecognized status, since there is no status changing event. So, settings app wouldn't show the "Format SDcard" button.
3. Plug->enable share->disable share->unplug
   Volume status changed: idle->shared->idle->checking->idle
   system app detectes the sdcard is unrecognized status, so settings app shows the "Format SDcard" button.
Hi Ian

As our previous discussion, you might consider MOUNT-FAIL volume status as unrecognized sdcard and use it in the settings app after system reboot.
If you need any help, please feel free to info me.
Thanks.
Flags: needinfo?(iliu)
The WIP patch proposed in bug 1123567 should fix the issue.
Flags: needinfo?(iliu)
See Also: → 1123567
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.